summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-17 11:41:57 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-17 11:44:12 +0200
commit3c2522e71bf48fd10e1e400f6d8c7fa41b957356 (patch)
treec4b43edca3efbd5e63ba7ef8f438c21bb6c19ac3 /dev-python
parentsys-libs/timezone-data: keyword 2023c for ~arm64-macos (diff)
downloadgentoo-3c2522e71bf48fd10e1e400f6d8c7fa41b957356.tar.gz
gentoo-3c2522e71bf48fd10e1e400f6d8c7fa41b957356.tar.bz2
gentoo-3c2522e71bf48fd10e1e400f6d8c7fa41b957356.zip
dev-python/pyproject-api: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyproject-api/Manifest2
-rw-r--r--dev-python/pyproject-api/pyproject-api-1.5.1.ebuild41
-rw-r--r--dev-python/pyproject-api/pyproject-api-1.5.2.ebuild41
3 files changed, 0 insertions, 84 deletions
diff --git a/dev-python/pyproject-api/Manifest b/dev-python/pyproject-api/Manifest
index c551f70376db..bdfd9819129c 100644
--- a/dev-python/pyproject-api/Manifest
+++ b/dev-python/pyproject-api/Manifest
@@ -1,3 +1 @@
-DIST pyproject_api-1.5.1.tar.gz 22081 BLAKE2B 53ee778b4e04cac2f16ecd054adc7fd86373d6402f80d485fe22457252684f774b6a5df23d08cf6c6b1f96964d6dc1b1cc9014415f3d9105ffbb09421f69a11e SHA512 31936d242861027ea892e86219f430371aae18631c92893cefc8fb8fc02315906857ee57e5412eed62bf584e0bd24cca7ba82471c0ac6a72c71e8e93b8285a3e
-DIST pyproject_api-1.5.2.tar.gz 21926 BLAKE2B 337fa749273273e0d4c761876ac1b9ec25c02ad206dd222790717dde44ad82409d5200b94c2b5d35984116b1c88cfa10b93c699e684ff51b3235b936e35fe0ee SHA512 ee12ec0dccce0130bca703886c40ac21802f58fb7683370592f9dabbf83366939f5032d7f55c6b712cfa4fa0cf34d88fc37a05eae9d811b34fe9c7377886b8d7
DIST pyproject_api-1.5.3.tar.gz 22128 BLAKE2B 0004682932717db0926e0e080ee78a9b24a9fc0025769e0cbe300bcf0ed50ddbabb52c257e2860718f87707072701ba2912e0fbf32b5481bd2993fb2b304e7c7 SHA512 719c4a9d747d8b5fbf3ac86c5f828c9fe10592a5dd71f68ffe308a8b73036de6777e32ddbcbaa7a45dcb23d0963555abab3e0fc4ddfc5eaac864b8892a1b67b8
diff --git a/dev-python/pyproject-api/pyproject-api-1.5.1.ebuild b/dev-python/pyproject-api/pyproject-api-1.5.1.ebuild
deleted file mode 100644
index c4ca49c47427..000000000000
--- a/dev-python/pyproject-api/pyproject-api-1.5.1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="API to interact with the python pyproject.toml based projects"
-HOMEPAGE="
- https://github.com/tox-dev/pyproject-api/
- https://pypi.org/project/pyproject-api/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- >=dev-python/packaging-23[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/tomli-2.0.1[${PYTHON_USEDEP}]
- ' 3.{8..10})
-"
-BDEPEND="
- >=dev-python/hatch-vcs-0.3.0[${PYTHON_USEDEP}]
- test? (
- >=dev-python/pytest-mock-3.10[${PYTHON_USEDEP}]
- >=dev-python/wheel-0.38.4[${PYTHON_USEDEP}]
- >=dev-python/virtualenv-20.17.1[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # requires Python 2 installed
- tests/test_frontend.py::test_can_build_on_python_2
-)
diff --git a/dev-python/pyproject-api/pyproject-api-1.5.2.ebuild b/dev-python/pyproject-api/pyproject-api-1.5.2.ebuild
deleted file mode 100644
index 3bc4973c1714..000000000000
--- a/dev-python/pyproject-api/pyproject-api-1.5.2.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="API to interact with the python pyproject.toml based projects"
-HOMEPAGE="
- https://github.com/tox-dev/pyproject-api/
- https://pypi.org/project/pyproject-api/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-
-RDEPEND="
- >=dev-python/packaging-23.1[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/tomli-2.0.1[${PYTHON_USEDEP}]
- ' 3.{8..10})
-"
-BDEPEND="
- >=dev-python/hatch-vcs-0.3.0[${PYTHON_USEDEP}]
- test? (
- >=dev-python/pytest-mock-3.10[${PYTHON_USEDEP}]
- >=dev-python/setuptools-67.8[${PYTHON_USEDEP}]
- >=dev-python/wheel-0.40[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # requires Python 2 installed
- tests/test_frontend.py::test_can_build_on_python_2
-)