summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-07-30 16:28:19 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-30 16:39:32 +0200
commit300155f33382fea506d5cbfd1bf6518b827ad3ff (patch)
treef269e033827beb0022bdbcf08cafb9dca90101a0 /dev-python
parentdev-python/pytest-asyncio: New package (diff)
downloadgentoo-300155f33382fea506d5cbfd1bf6518b827ad3ff.tar.gz
gentoo-300155f33382fea506d5cbfd1bf6518b827ad3ff.tar.bz2
gentoo-300155f33382fea506d5cbfd1bf6518b827ad3ff.zip
dev-python/aiohttp-socks: Add testing code, correct deps, EAPI 7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/aiohttp-socks/aiohttp-socks-0.2.2.ebuild26
1 files changed, 20 insertions, 6 deletions
diff --git a/dev-python/aiohttp-socks/aiohttp-socks-0.2.2.ebuild b/dev-python/aiohttp-socks/aiohttp-socks-0.2.2.ebuild
index 52758134c3e5..e38b826b03d8 100644
--- a/dev-python/aiohttp-socks/aiohttp-socks-0.2.2.ebuild
+++ b/dev-python/aiohttp-socks/aiohttp-socks-0.2.2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PYTHON_COMPAT=( python3_{6,7} )
@@ -14,10 +14,24 @@ SRC_URI="https://github.com/romis2012/aiohttp-socks/archive/${PV}.tar.gz -> ${P}
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+IUSE="test"
+# Tests require Internet access
+RESTRICT="test"
-RDEPEND="
- >=dev-python/aiohttp-2.3.2[${PYTHON_USEDEP}]
-"
+RDEPEND=">=dev-python/aiohttp-2.3.2[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ net-proxy/3proxy
+ )"
-DOCS=( README.md )
+python_configure_all() {
+ rm tests/3proxy/bin/*/* || die
+ ln -s "$(type -P 3proxy)" tests/3proxy/bin/linux/ || die
+}
+
+python_test() {
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+}