summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2019-12-02 13:02:57 +0100
committerLouis Sautier <sbraz@gentoo.org>2019-12-02 13:15:58 +0100
commit130e9502b0a2b9cefc0445fa081c8f61fe2f2004 (patch)
tree0e8fe3f2ddecff2bb1499eaf3e2ce12a5b7db201 /dev-python
parentvirtual/rubygems: cleanup (diff)
downloadgentoo-130e9502b0a2b9cefc0445fa081c8f61fe2f2004.tar.gz
gentoo-130e9502b0a2b9cefc0445fa081c8f61fe2f2004.tar.bz2
gentoo-130e9502b0a2b9cefc0445fa081c8f61fe2f2004.zip
dev-python/jaraco-text: bump to 3.2.0, add Python 3.8 support
Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/jaraco-text/Manifest1
-rw-r--r--dev-python/jaraco-text/jaraco-text-3.2.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/jaraco-text/Manifest b/dev-python/jaraco-text/Manifest
index cc89054018ad..f601b8de7aeb 100644
--- a/dev-python/jaraco-text/Manifest
+++ b/dev-python/jaraco-text/Manifest
@@ -1,3 +1,4 @@
DIST jaraco.text-1.10.1.tar.gz 8790 BLAKE2B 268c13a9a84c4b29ac9141d8a43c716d8248b87c2b71f6bb8a34c2cf1568acdd012e84b1be0469f70ee8e102f723e218b6d551a9bd0cab5192a28d712ed39f03 SHA512 5c09b90f586d5ddf7419013f7e36814598337c257e6bd1c1eec993d7df021440798ec9300a6d45c960c5458c4197b458d1863f478b60a9a003241e98a644f28e
DIST jaraco.text-3.0.1.tar.gz 11969 BLAKE2B 8eed750e81aa6a82baaa25483a2b60d2adb9f7a1769f92556a3a5c3fc53c3dc63a7910615317007dd0b934e73987da5de53d0e52a3cd44da955b717b48348dd4 SHA512 dcac7de44de4f1ae4dcfbe3e1857a4017b967bbbfc46df05cbf7d0f319a0f841440406b75a6e84b3283d8946ee1753c99f16438228dd2393fa023571c3911a10
DIST jaraco.text-3.1.tar.gz 13220 BLAKE2B f52ca11b8b20a42d2c36102d4d48cf27952314bf5304521fde020c6e52e92bf6f534b2c6c4d8cc0b73aec8bd118030e455d8a5eeb19fb4e927105fa7e4477817 SHA512 9edd50e3b67d40a1a5dfe8796dd55f80aac52cef9ba2f1ad565cf597c1ff8824d2c61900cedd104210b60dcc6dced8c01321af67e2e1a755be89e1c15945da1e
+DIST jaraco.text-3.2.0.tar.gz 14279 BLAKE2B aa8c8903bac61db3d1017408e1aa525f66060422c27b754af343a64e586b64c6623b66881bea62b9b2e89821a40c933d54c9a8cddc7bda08ac108ad08a9524dc SHA512 4107ef1078b44714b6ee5fb6ebd2bb7c35415debc6eaedd8bc18a70a2936cc7c7757acd7b3fac9587201ef52a25d9b29e49f2385a0a08afffb1d0c3de6ecc377
diff --git a/dev-python/jaraco-text/jaraco-text-3.2.0.ebuild b/dev-python/jaraco-text/jaraco-text-3.2.0.ebuild
new file mode 100644
index 000000000000..af0f4eceead8
--- /dev/null
+++ b/dev-python/jaraco-text/jaraco-text-3.2.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7,8}} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+DESCRIPTION="Text utilities used by other projects by developer jaraco"
+HOMEPAGE="https://github.com/jaraco/jaraco.text"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/jaraco-functools[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/namespace-jaraco-2[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/importlib_resources[${PYTHON_USEDEP}]' python{2_7,3_{5,6}})
+"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+ )
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+distutils_enable_sphinx docs \
+ ">=dev-python/jaraco-packaging-3.2" \
+ ">=dev-python/rst-linker-1.9"
+
+python_test() {
+ # Override pytest options to skip flake8
+ PYTHONPATH=. pytest -vv --override-ini="addopts=--doctest-modules" \
+ || die "tests failed with ${EPYTHON}"
+}
+
+# https://wiki.gentoo.org/wiki/Project:Python/Namespace_packages#File_collisions_between_pkgutil-style_packages
+python_install() {
+ rm "${BUILD_DIR}"/lib/jaraco/__init__.py || die
+ # note: eclass may default to --skip-build in the future
+ distutils-r1_python_install --skip-build
+}