summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-13 06:24:42 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-13 06:31:02 +0200
commit12e947f90c8350f394c2feaef67bfcf3db809a6a (patch)
treef40920404f67a0adc3bedec3e563eddf67174f24 /dev-python
parentdev-python/orjson: Bump to 3.9.9 (diff)
downloadgentoo-12e947f90c8350f394c2feaef67bfcf3db809a6a.tar.gz
gentoo-12e947f90c8350f394c2feaef67bfcf3db809a6a.tar.bz2
gentoo-12e947f90c8350f394c2feaef67bfcf3db809a6a.zip
dev-python/shapely: Bump to 2.0.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/shapely/Manifest1
-rw-r--r--dev-python/shapely/shapely-2.0.2.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/shapely/Manifest b/dev-python/shapely/Manifest
index a09521499b0c..19c8f0fa186e 100644
--- a/dev-python/shapely/Manifest
+++ b/dev-python/shapely/Manifest
@@ -1 +1,2 @@
DIST shapely-2.0.1.gh.tar.gz 325843 BLAKE2B f6ae72c8544c236f6761be5bbc358161232319377a76d297eda317e61b97185ae62126b27963cb83798593ec2ce3f29d99bd74113e356b69b54da7586927d43b SHA512 878a4857f5408e2f779566f4885b3336eecd2ecfd685e9be3e306af2720ca4da3f7a1159ae65ad1eba441e0f9b347176d6c144563a9562ed8213e6f964d183c7
+DIST shapely-2.0.2.gh.tar.gz 330120 BLAKE2B 01630239075c767897635fb25573bc37469ecb7b03d62cef2d82b95a8bd7216864087b9bbcaa46c75850f2048efac2b171f2a78090bf4cd846e882fd8b549942 SHA512 7d19984a1fae9a4ec6abaa2f88712ff442272019976427a915ccd3493e3dc8fe169c5ab3aacf71f3104fc325f93b1877bfcbe9c44968b661feccc38eeeb16f9a
diff --git a/dev-python/shapely/shapely-2.0.2.ebuild b/dev-python/shapely/shapely-2.0.2.ebuild
new file mode 100644
index 000000000000..4cc5dc4fdc4b
--- /dev/null
+++ b/dev-python/shapely/shapely-2.0.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=${P/_p/.post}
+DESCRIPTION="Geometric objects, predicates, and operations"
+HOMEPAGE="
+ https://pypi.org/project/shapely/
+ https://github.com/shapely/shapely/
+"
+SRC_URI="
+ https://github.com/shapely/shapely/archive/${PV/_p/.post}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+DEPEND="
+ >=sci-libs/geos-3.9
+"
+RDEPEND="
+ ${DEPEND}
+ dev-python/numpy[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${DEPEND}
+ >=dev-python/cython-0.29.32[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ rm -rf shapely || die
+ epytest --pyargs shapely
+}