summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-18 22:08:17 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-18 22:56:59 +0200
commit0a1b8eef55a071232d7b8e13d6fe687030ac2504 (patch)
tree84e99681220654c4f5a117619c1fcdf170e69fb3 /dev-python
parentdev-python/scikit-build: Remove old (diff)
downloadgentoo-0a1b8eef55a071232d7b8e13d6fe687030ac2504.tar.gz
gentoo-0a1b8eef55a071232d7b8e13d6fe687030ac2504.tar.bz2
gentoo-0a1b8eef55a071232d7b8e13d6fe687030ac2504.zip
dev-python/pyglet: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyglet/Manifest2
-rw-r--r--dev-python/pyglet/pyglet-1.5.18.ebuild62
-rw-r--r--dev-python/pyglet/pyglet-1.5.20.ebuild61
3 files changed, 0 insertions, 125 deletions
diff --git a/dev-python/pyglet/Manifest b/dev-python/pyglet/Manifest
index 2f828f685a61..a7203707f919 100644
--- a/dev-python/pyglet/Manifest
+++ b/dev-python/pyglet/Manifest
@@ -1,4 +1,2 @@
-DIST pyglet-1.5.18.tar.gz 6440818 BLAKE2B cb7832000e0df96cd794f8eff9ba41aac8571542fbc45d1607df3935a7ed53ba8fd46b6bba40f6d5d53adfb2024aad1930cba1889b5d40d342457f7dc06db5d1 SHA512 d6ceddecccb36a90bef38c4a1608e866bb90ebb72eaaff693a2eb34678c7a50c99213a69042c569c22d54cc04a4b11d37ea8da47425958505261ebcf99bd28ce
DIST pyglet-1.5.19.tar.gz 6446786 BLAKE2B fef21122cf31718e0a796b3be4edf386bf477dc4fa6480970159b9d361e489417c9cad1df1060290bc1678408eed36e287c15da442275beaa8d354c268568411 SHA512 7ef85d91cdcafef8cf097e96bd34e800002824696ffbc1132c2dd776fe9d3c7be0b5633fff1cb10344fcc1aafa3c0c9a75547ad374be091f35aa99527869ab4b
-DIST pyglet-1.5.20.tar.gz 6517626 BLAKE2B 41b63bc650823fc3065f71215822d39a1e3f40b02f75401ab8fab6be7d3d8848813c721f400ec923fa29f5d5b0a66f7d7af905caae10f1ea5ab5241cbead1c87 SHA512 da1519a2c196348d8af90f280ffc90b0f46d2d325403a5ca53fa663aab161d13802e22259124c3af77fbf5814c06d8920c0147b30c22db74fff885091e9a9ad0
DIST pyglet-1.5.21.tar.gz 6516128 BLAKE2B ab7f23dc4ba48450f3da4efd30fadd089777f50b5392945636886192e89e230475f5bff9ba02cd166295423ed67f98b89fd186d18601504fe0f024c203a198c8 SHA512 3df0134dbfdeb15baae059bae489158273fd4797d5dc4da903ac2fdd58ae9e291e8d5371ebe545bd125a1670adfec84cb9d9f4f11841d594f3e4d38e5910ce2a
diff --git a/dev-python/pyglet/pyglet-1.5.18.ebuild b/dev-python/pyglet/pyglet-1.5.18.ebuild
deleted file mode 100644
index 24e77b128b01..000000000000
--- a/dev-python/pyglet/pyglet-1.5.18.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..9} )
-
-inherit distutils-r1 virtualx xdg-utils
-
-DESCRIPTION="Cross-platform windowing and multimedia library for Python"
-HOMEPAGE="http://pyglet.org/"
-SRC_URI="https://github.com/pyglet/pyglet/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 x86 ~amd64-linux ~x86-linux"
-IUSE="examples image +sound"
-
-BDEPEND="
- test? (
- dev-python/pillow[${PYTHON_USEDEP}]
- dev-python/gst-python[${PYTHON_USEDEP}]
- )
-"
-RDEPEND="
- virtual/glu
- virtual/opengl
- image? ( || (
- dev-python/pillow[${PYTHON_USEDEP}]
- x11-libs/gtk+:2
- ) )
- sound? ( || (
- media-libs/openal
- media-sound/pulseaudio
- ) )
-"
-# ffmpeg? ( media-libs/avbin-bin )
-
-DOCS=( DESIGN NOTICE README.md RELEASE_NOTES )
-
-distutils_enable_tests pytest
-
-src_test() {
- virtx distutils-r1_src_test
-}
-
-python_test() {
- xdg_environment_reset
-
- # Specify path to avoid running interactive tests
- # We could add in integration tests, but they're slow
- epytest tests/unit
-}
-
-python_install_all() {
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-
- distutils-r1_python_install_all
-}
diff --git a/dev-python/pyglet/pyglet-1.5.20.ebuild b/dev-python/pyglet/pyglet-1.5.20.ebuild
deleted file mode 100644
index 247321eafd39..000000000000
--- a/dev-python/pyglet/pyglet-1.5.20.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..9} )
-inherit distutils-r1 virtualx xdg-utils
-
-DESCRIPTION="Cross-platform windowing and multimedia library for Python"
-HOMEPAGE="http://pyglet.org/"
-SRC_URI="https://github.com/pyglet/pyglet/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="examples image +sound"
-
-BDEPEND="
- test? (
- dev-python/pillow[${PYTHON_USEDEP}]
- dev-python/gst-python[${PYTHON_USEDEP}]
- )
-"
-RDEPEND="
- virtual/glu
- virtual/opengl
- image? ( || (
- dev-python/pillow[${PYTHON_USEDEP}]
- x11-libs/gtk+:2
- ) )
- sound? ( || (
- media-libs/openal
- media-sound/pulseaudio
- ) )
-"
-# ffmpeg? ( media-libs/avbin-bin )
-
-DOCS=( DESIGN NOTICE README.md RELEASE_NOTES )
-
-distutils_enable_tests pytest
-
-src_test() {
- virtx distutils-r1_src_test
-}
-
-python_test() {
- xdg_environment_reset
-
- # Specify path to avoid running interactive tests
- # We could add in integration tests, but they're slow
- epytest tests/unit
-}
-
-python_install_all() {
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-
- distutils-r1_python_install_all
-}