summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-17 11:51:17 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-17 14:35:12 +0200
commit06a0f4cf656454a320f74ef9f8756dd18e32aa3a (patch)
tree9836ad22a953a1043e6096f1b78c4760dcd6705f /dev-python
parentdev-python/openstacksdk: Bump to 3.3.0 (diff)
downloadgentoo-06a0f4cf656454a320f74ef9f8756dd18e32aa3a.tar.gz
gentoo-06a0f4cf656454a320f74ef9f8756dd18e32aa3a.tar.bz2
gentoo-06a0f4cf656454a320f74ef9f8756dd18e32aa3a.zip
dev-python/sabctools: Bump to 8.2.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/sabctools/Manifest1
-rw-r--r--dev-python/sabctools/sabctools-8.2.4.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/sabctools/Manifest b/dev-python/sabctools/Manifest
index c7b9575cecd8..3683e8b7a95c 100644
--- a/dev-python/sabctools/Manifest
+++ b/dev-python/sabctools/Manifest
@@ -1,2 +1,3 @@
DIST sabctools-8.1.0.gh.tar.gz 8963885 BLAKE2B 36d6bbc34f636ac4e892f941eb6e583166ee1f5f740440b3f07faacddf7715d8b4c642a4e6252ece1bdef69017be3d04ce5d6c8e36479bb176e4cd0635f1567d SHA512 862c39f2e386622b528f120a431f214e1e2e92b7c5a751e47d0768f40ce06ad2736d867f7ac2e1810d676e980312bbfedd29951cbadeddefe75246cdcf53fcc6
DIST sabctools-8.2.3.gh.tar.gz 8974172 BLAKE2B 15b15cb1a5b7e923cc43e5e619e02f09d34f69d05d692b11bf3de8b12a1f33efcf6cf8cd8b251c646f1e2be7e2941c755e2e30a205b9e066d280038b287b262d SHA512 7bf1b0e9f55d9f6384166cca911c0d1dd79b3d4d1c33effe295fe4e053394a674a36548e5241a86817ce109a1165e0814954550436f5381daddfc8c1a7c188e5
+DIST sabctools-8.2.4.gh.tar.gz 8974209 BLAKE2B ddea09ec8a0a4b34779f1e8fe5fc4712ce7dd311ded308c77fb7925b8236e740bb8c345998f7e8e92837c7c19e9c4bbaf0bd0c2ac2b967cf98aa660105814d59 SHA512 2e79a7b854be51b04a91fffb3401a4bd2e7c6d74d1815d1228a9fca97b79c599463a062386f85555ba6ce9a3e8130a1615a3c576fe5411b7dff48c37eaf6b34b
diff --git a/dev-python/sabctools/sabctools-8.2.4.ebuild b/dev-python/sabctools/sabctools-8.2.4.ebuild
new file mode 100644
index 000000000000..0632a9976480
--- /dev/null
+++ b/dev-python/sabctools/sabctools-8.2.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_PN="sabctools"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Module providing raw yEnc encoding/decoding for SABnzbd"
+HOMEPAGE="
+ https://github.com/sabnzbd/sabctools/
+ https://pypi.org/project/sabctools/
+"
+SRC_URI="
+ https://github.com/sabnzbd/${MY_PN}/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/portend[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( README.md doc/yenc-draft.1.3.txt )
+
+distutils_enable_tests pytest