summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-24 14:06:39 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-24 16:31:24 +0200
commit012936bfa70e0dc726e31147c0a6ebe3f50ca123 (patch)
tree1ca854a6804ef7da5dc06133f87494cc7b6663e2 /dev-python
parentdev-python/arrow: Bump to 0.15.8 (diff)
downloadgentoo-012936bfa70e0dc726e31147c0a6ebe3f50ca123.tar.gz
gentoo-012936bfa70e0dc726e31147c0a6ebe3f50ca123.tar.bz2
gentoo-012936bfa70e0dc726e31147c0a6ebe3f50ca123.zip
dev-python/botocore: Bump to 1.17.27
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.17.27.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 38a6975ed624..3b677fd741f6 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -1,3 +1,4 @@
DIST botocore-1.16.26.tar.gz 6458468 BLAKE2B e753f7dcb3d75a86da78536883e44cbd493fd3ff48fae86e5e1959e55d2d66fe8dcb33ee46af51b39390ce7d2227bdb193a827932b53dc5a4b56f985faeebd31 SHA512 66ba4e9bd8ae72a31fa093dc7d8eccd646a12381086f524e3bd63d6031f2d75bad5e241f08e5588a6ac6c16eac693d0410b1858641bf8e59decfb1e6ed16b360
DIST botocore-1.17.20.tar.gz 6557688 BLAKE2B a4d17d436a7af1a9825ebc0bcb23d0cb32ba90dc1e359b7c248347351321d50d91fd7dcf35afbebcd714f1e1ee37300db5bc22d071404d9403d7812c9fa3e3bc SHA512 db59ee57cc01742f37b95e3655a55e7631458eba74f8e8b808199892921240c8d108e2db4144f50dcd1d00286ff9cc24f38f866baca0a4df26b4771159d09aff
DIST botocore-1.17.23.tar.gz 6564852 BLAKE2B cc1da91f4a45964fe684b015de9db253059241f654dac93901cde5dc24f3ab3595ecd201be91bed36236bb885c7ec7aed998025f6c0ea8b050c13d17a6431238 SHA512 93af672e8d110ab4989e9abc20b3bbb1a6c9050c379bb1db8542e9027e6a4ee82083645c59211204d7110e112d393f80f87d15b77337a4d73358f43d39f6e52f
+DIST botocore-1.17.27.tar.gz 6637309 BLAKE2B 8c3d8d27b13c55c11b4934e0af35bb0a01c67e0c30d33ce54710d3e3c967101c5d9258fc2317f86c9f8271044e977015b185015aafd3af748fe581f3120ea32d SHA512 9dc3341b6de7801da13f71730bcb2bf9c4295618303a1c98973cabb2aef947b5756352f3a9939b8fbe04a92c3a7cde6ed88f55c982f7dc412f7dff898bc75bc2
diff --git a/dev-python/botocore/botocore-1.17.27.ebuild b/dev-python/botocore/botocore-1.17.27.ebuild
new file mode 100644
index 000000000000..c08c6f6ff899
--- /dev/null
+++ b/dev-python/botocore/botocore-1.17.27.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+ "${FILESDIR}/botocore-1.16.7-unlock-deps.patch"
+)
+
+distutils_enable_sphinx docs \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+src_prepare() {
+ # py3.9
+ find -name '*.py' -exec \
+ sed -i -e 's:cElementTree:ElementTree:' {} + || die
+ # very unstable
+ sed -i -e 's:test_stress_test_token_bucket:_&:' \
+ tests/functional/retries/test_bucket.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # note: suites need to be run separately as one of the unit tests
+ # seems to be leaking mocks and breaking a few functional tests
+ nosetests -v tests/unit ||
+ die "unit tests failed under ${EPYTHON}"
+ nosetests -v tests/functional ||
+ die "functional tests failed under ${EPYTHON}"
+}