summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-12-15 21:15:03 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2023-12-15 21:15:03 +0200
commit004d54e3289137a4612d772d09a62782d04882a1 (patch)
treec7defd7c8068d0a6b78d649ed021ad7b94c9ea95 /dev-python
parentdev-python/pyqt-distutils: treeclean (diff)
downloadgentoo-004d54e3289137a4612d772d09a62782d04882a1.tar.gz
gentoo-004d54e3289137a4612d772d09a62782d04882a1.tar.bz2
gentoo-004d54e3289137a4612d772d09a62782d04882a1.zip
dev-python/pushbullet-py: treeclean
Closes: https://bugs.gentoo.org/916670 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pushbullet-py/Manifest1
-rw-r--r--dev-python/pushbullet-py/metadata.xml13
-rw-r--r--dev-python/pushbullet-py/pushbullet-py-0.12.0-r1.ebuild50
3 files changed, 0 insertions, 64 deletions
diff --git a/dev-python/pushbullet-py/Manifest b/dev-python/pushbullet-py/Manifest
deleted file mode 100644
index 89865df0ed55..000000000000
--- a/dev-python/pushbullet-py/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST pushbullet.py-0.12.0.tar.gz 23769 BLAKE2B 096c5995bee7dba65b7f385c2cbd70d839b22a07b26dd1ad9c1ef64244ba97e3c2f077c9eb0ca46a2ccd7df6a27e3ee3d4d55522986e832ca109d003e77fbad6 SHA512 5394fb8e8631ba00c610c36380e2c917231207ecd25bb4e2f1f0e44c232f4dd33b99ce5b1973467844b7f46f275ea812620e6549afd42915ee8fc13e1650f758
diff --git a/dev-python/pushbullet-py/metadata.xml b/dev-python/pushbullet-py/metadata.xml
deleted file mode 100644
index 78a1ad74cd84..000000000000
--- a/dev-python/pushbullet-py/metadata.xml
+++ /dev/null
@@ -1,13 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>sbraz@gentoo.org</email>
- <name>Louis Sautier</name>
- </maintainer>
- <upstream>
- <remote-id type="pypi">pushbullet.py</remote-id>
- <remote-id type="github">richard-better/pushbullet.py</remote-id>
- <bugs-to>https://github.com/richard-better/pushbullet.py/issues</bugs-to>
- </upstream>
-</pkgmetadata>
diff --git a/dev-python/pushbullet-py/pushbullet-py-0.12.0-r1.ebuild b/dev-python/pushbullet-py/pushbullet-py-0.12.0-r1.ebuild
deleted file mode 100644
index 20621dd4a6c7..000000000000
--- a/dev-python/pushbullet-py/pushbullet-py-0.12.0-r1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYPI_PN=${PN/-/.}
-PYTHON_COMPAT=( pypy3 python3_{9..11} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="A simple python client for pushbullet.com"
-HOMEPAGE="
- https://github.com/richard-better/pushbullet.py/
- https://pypi.org/project/pushbullet.py/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples"
-
-RDEPEND="
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/python-magic[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/websocket-client[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- # Skip tests which require internet access
- PUSHBULLET_API_KEY= epytest -k "not (test_auth or test_decryption)"
-}
-
-python_install_all() {
- if use examples; then
- docompress -x "/usr/share/doc/${PF}/examples"
- docinto examples
- dodoc -r example/.
- fi
- distutils-r1_python_install_all
-}