summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-23 16:31:24 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-23 17:36:22 +0100
commit8bb9239b485f6dac584544aa6733aa91da154607 (patch)
tree3811bdea80250bad164d337a8e0844df5cb8394f /dev-python/zope-i18nmessageid
parentdev-python/pdm-pep517: Bump to 1.1.3 (diff)
downloadgentoo-8bb9239b485f6dac584544aa6733aa91da154607.tar.gz
gentoo-8bb9239b485f6dac584544aa6733aa91da154607.tar.bz2
gentoo-8bb9239b485f6dac584544aa6733aa91da154607.zip
dev-python/zope-i18nmessageid: Bump to 6.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/zope-i18nmessageid')
-rw-r--r--dev-python/zope-i18nmessageid/Manifest1
-rw-r--r--dev-python/zope-i18nmessageid/zope-i18nmessageid-6.0.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/zope-i18nmessageid/Manifest b/dev-python/zope-i18nmessageid/Manifest
index d6fcde37dcba..dac790ea795d 100644
--- a/dev-python/zope-i18nmessageid/Manifest
+++ b/dev-python/zope-i18nmessageid/Manifest
@@ -1 +1,2 @@
DIST zope.i18nmessageid-5.1.1.tar.gz 30589 BLAKE2B aa87ecc7b757c2f3ff877ea908df102477b5f888067a6bf98aab6467adaf7baa713c5b413f528cc0010b4082d03b48d069537dbf223713ed914982eb8f040433 SHA512 4762dc67d4b665ede25eaaeae1458257fef994207a887f128fb5c64685bcde08bc17e24890cf36a14febb57295813c9152f14aeea854493e4197702bb4e3d719
+DIST zope.i18nmessageid-6.0.0.tar.gz 27791 BLAKE2B 3589c46c0405f21e50df3eae1bc3aaabccd88d16cbc696634e31dffa866910965d050aef50534d9a04799d918830e78e8b977162409d7862e72e17eed4740c15 SHA512 415cf30bc571032719e39c4fdf12f3d8e877b975774a87fea22ff0577d83e4b1582c0af9744514b46253ffee04c4599c02803798cef2b514e8111c7eea17e34a
diff --git a/dev-python/zope-i18nmessageid/zope-i18nmessageid-6.0.0.ebuild b/dev-python/zope-i18nmessageid/zope-i18nmessageid-6.0.0.ebuild
new file mode 100644
index 000000000000..d3e13bc75066
--- /dev/null
+++ b/dev-python/zope-i18nmessageid/zope-i18nmessageid-6.0.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN/-/.}
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Zope support for i18nmessageid (tagging source of i18n strings)"
+HOMEPAGE="
+ https://pypi.org/project/zope.i18nmessageid/
+ https://github.com/zopefoundation/zope.i18nmessageid/
+"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ !dev-python/namespace-zope
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # strip rdep specific to namespaces
+ sed -i -e "s:'setuptools',::" setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+python_test() {
+ cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
+ distutils_write_namespace zope
+ eunittest
+}