summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-13 00:12:47 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-13 00:58:17 +0200
commit9da76417e849777e4aa77ac75476dfd2ae74f788 (patch)
treef1c4316a4ea50ade39f3c549dbb3db0a9980d6bd /dev-python/zipp
parentdev-python/moto: Unbound indirect ecdsa dep (diff)
downloadgentoo-9da76417e849777e4aa77ac75476dfd2ae74f788.tar.gz
gentoo-9da76417e849777e4aa77ac75476dfd2ae74f788.tar.bz2
gentoo-9da76417e849777e4aa77ac75476dfd2ae74f788.zip
dev-python/zipp: Enable py3.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/zipp')
-rw-r--r--dev-python/zipp/zipp-1.0.0.ebuild4
-rw-r--r--dev-python/zipp/zipp-3.1.0.ebuild2
2 files changed, 3 insertions, 3 deletions
diff --git a/dev-python/zipp/zipp-1.0.0.ebuild b/dev-python/zipp/zipp-1.0.0.ebuild
index c84afd3ef586..7b3294151af0 100644
--- a/dev-python/zipp/zipp-1.0.0.ebuild
+++ b/dev-python/zipp/zipp-1.0.0.ebuild
@@ -3,7 +3,8 @@
EAPI=7
-PYTHON_COMPAT=( pypy3 python{2_7,3_{6,7,8}} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( pypy3 python{2_7,3_{6..9}} )
inherit distutils-r1
@@ -18,7 +19,6 @@ IUSE="test"
RDEPEND="dev-python/more-itertools[${PYTHON_USEDEP}]"
BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
test? (
${RDEPEND}
$(python_gen_cond_dep '
diff --git a/dev-python/zipp/zipp-3.1.0.ebuild b/dev-python/zipp/zipp-3.1.0.ebuild
index 376bf2af0706..736fe71888a3 100644
--- a/dev-python/zipp/zipp-3.1.0.ebuild
+++ b/dev-python/zipp/zipp-3.1.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( pypy3 python3_{6,7,8} )
+PYTHON_COMPAT=( pypy3 python3_{6..9} )
# [options.entry_points] is present in setup.cfg but it is empty
DISTUTILS_USE_SETUPTOOLS=manual