summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-13 09:05:46 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-13 13:12:11 +0100
commitb27d734ce0fd21c6c1fee2ada4d91b56c7711935 (patch)
treefbc0e361b2f9bc3b9681cb1d791b00f9fdbc892b /dev-python/zeroconf
parentdev-python/sympy: Bump to 1.7.1 (diff)
downloadgentoo-b27d734ce0fd21c6c1fee2ada4d91b56c7711935.tar.gz
gentoo-b27d734ce0fd21c6c1fee2ada4d91b56c7711935.tar.bz2
gentoo-b27d734ce0fd21c6c1fee2ada4d91b56c7711935.zip
dev-python/zeroconf: Bump to 0.28.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/zeroconf')
-rw-r--r--dev-python/zeroconf/Manifest1
-rw-r--r--dev-python/zeroconf/zeroconf-0.28.7.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/zeroconf/Manifest b/dev-python/zeroconf/Manifest
index 42234f5e00d9..30e0c3bfd214 100644
--- a/dev-python/zeroconf/Manifest
+++ b/dev-python/zeroconf/Manifest
@@ -1,2 +1,3 @@
+DIST python-zeroconf-0.28.7.gh.tar.gz 60821 BLAKE2B e8c99505d1b149319552c808ee17bd3cd37a016c094d5f273f5d3545670ecf6f9cff58178293816e9cd671cf9e342b0a99641d6b9b3d32626dac4e72d983380e SHA512 8cc5c9b2e964c170c2aa53a3c07f2cd634cb113737fdf2e7a924b0b1c5ffb7c2d1e97b589cce36a4216f427e0e64dfba373f9f96b6117e835a9aa68a911edea0
DIST zeroconf-0.24.4.tar.gz 51866 BLAKE2B dd71bda4b0759c61a3e5895e766dff6516ea81ca0c8c9f5a95a8093de8a3a9b15722b99a6af0092b02c1b292bcdb11c02c9f165003b56ca8a793f4a4ca8fd891 SHA512 71678521b05016a7404005a06c8109f861cc8bfe2b3375ac6f1da8f63771271a3d9a095a8db6ccea2e062c5cc28b750a50fbe69218de72646b13a5f03359ea17
DIST zeroconf-0.28.6.tar.gz 61487 BLAKE2B 2ded05d0e63d9f4918da925c179ee198dac68cf7a51d8f63beaaa697b04d297c7e892c97b1cedd51f9ab4af23e79e50bd3d85eb1af804c0fc0c67461501a508e SHA512 405786a25531efc42acf967838e74b67960b7ecdbee5db0633a56ba3e1774b9bd71fac58bcf29ab57ef6328560ee0f0f8cfa126ea42637ff53fb18c479a92f62
diff --git a/dev-python/zeroconf/zeroconf-0.28.7.ebuild b/dev-python/zeroconf/zeroconf-0.28.7.ebuild
new file mode 100644
index 000000000000..276d5ec5755d
--- /dev/null
+++ b/dev-python/zeroconf/zeroconf-0.28.7.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+inherit distutils-r1
+
+MY_P=python-zeroconf-${PV}
+DESCRIPTION="Pure Python Multicast DNS Service Discovery Library (Bonjour/Avahi compatible)"
+HOMEPAGE="
+ https://github.com/jstasiak/python-zeroconf/
+ https://pypi.org/project/zeroconf/"
+SRC_URI="
+ https://github.com/jstasiak/python-zeroconf/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND=">=dev-python/ifaddr-0.1.7[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # broken in network-sandbox
+ sed -e 's:test_launch_and_close:_&:' \
+ -e 's:test_integration_with_listener_ipv6:_&:' \
+ -i zeroconf/test.py || die
+ distutils-r1_src_prepare
+}