summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-14 21:47:14 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-14 22:02:07 +0100
commit62f1b46257c95aac76c5b800cc950e888e09de01 (patch)
tree18fb814ac6e530af2429f6284bfca34e33444e43 /dev-python/yarl
parentgames-roguelike/stone-soup: Implement lua-single eclass (diff)
downloadgentoo-62f1b46257c95aac76c5b800cc950e888e09de01.tar.gz
gentoo-62f1b46257c95aac76c5b800cc950e888e09de01.tar.bz2
gentoo-62f1b46257c95aac76c5b800cc950e888e09de01.zip
dev-python/yarl: Bump to 1.6.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/yarl')
-rw-r--r--dev-python/yarl/Manifest1
-rw-r--r--dev-python/yarl/yarl-1.6.3.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/yarl/Manifest b/dev-python/yarl/Manifest
index 441f2760ead9..e608bad9e084 100644
--- a/dev-python/yarl/Manifest
+++ b/dev-python/yarl/Manifest
@@ -1,2 +1,3 @@
DIST yarl-1.6.0.tar.gz 175492 BLAKE2B e6e3ebb30a591fa1e94d07c353700b1ebf7c21a729d8c9a4cd582f591235d54dee40a109e28fb806893e281b9ab36ca2b1ca1cdf7f093587bde8a5a9c4e7bf89 SHA512 d08d2c4a906706bba3c1fad2b02e01299d076d9f6c1a1eb172d116d0ccbb1e6143b7dd959d242f2a1b5d450416bb15ab6e53ee9e05876b161d61ec23e054f29b
DIST yarl-1.6.2.tar.gz 177534 BLAKE2B a7a587387c8030737874b445007aac4a7bc7f5552238fb892cbb99325e9a3862c599a11df5738d79e47dd1073e29731f80bd941f351e4a7b1867780fba9986ce SHA512 5e3ab46216d567583558a6945127d0d8d758475636deb0733bae25fc869d842f05e996f06aa4a7dc6fd067f7e38afdc6e328cc8019735819d2a1cebc50ca165d
+DIST yarl-1.6.3.tar.gz 176823 BLAKE2B 58d36c6d18ef661cb08074153081f541fc98968107d71e7b501297f45f38de092804bba2ae89ddcf0da79b5d4fca62292a4c460bc9dff9d723d3958bc64ff84b SHA512 4c76b94198b8e334f4b4e71d92b0fe23f752d35e0c29bc68df99648b3f48fbb6e3dd8d7339138544e5dc8fbf64c15cb61678052670ac47edc5be958df819d42e
diff --git a/dev-python/yarl/yarl-1.6.3.ebuild b/dev-python/yarl/yarl-1.6.3.ebuild
new file mode 100644
index 000000000000..28fd8a84c1dc
--- /dev/null
+++ b/dev-python/yarl/yarl-1.6.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Yet another URL library"
+HOMEPAGE="https://github.com/aio-libs/yarl/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/multidict-4.0[${PYTHON_USEDEP}]
+ >=dev-python/idna-2.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/typing-extensions-3.7.4[${PYTHON_USEDEP}]
+ ' python3_{6,7} pypy3)
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.4.2-test-without-coverage.patch
+)