summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/yapsy
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/yapsy')
-rw-r--r--dev-python/yapsy/Manifest3
-rw-r--r--dev-python/yapsy/metadata.xml12
-rw-r--r--dev-python/yapsy/yapsy-1.10.423.ebuild27
-rw-r--r--dev-python/yapsy/yapsy-1.11.023.ebuild44
-rw-r--r--dev-python/yapsy/yapsy-1.11.223.ebuild44
5 files changed, 130 insertions, 0 deletions
diff --git a/dev-python/yapsy/Manifest b/dev-python/yapsy/Manifest
new file mode 100644
index 000000000000..12bd7daa83cb
--- /dev/null
+++ b/dev-python/yapsy/Manifest
@@ -0,0 +1,3 @@
+DIST Yapsy-1.10.423.tar.gz 152691 SHA256 9ba7767f63ab591c0ad3fc8b2bd11ac19a0fabb7259bcb1733858eab5bd9b1e1 SHA512 46447ac2cc2583fcb7fe1c89ded74654efc4d3c9ecc79f955db1e0e9875c9ac2f18e12de3b5f0886c34fdbcdadf601523eb2cd1d8e74b24b791f4f6900dcdcc3 WHIRLPOOL 7dbd717a40296f05da0aec09e05b40c039613d0dc8622b337aa21ddc1919c71e48d9e9ed31c8cf4b89a9c06e5752da2eb684bbdcc843c7f1e8e672920e10d20d
+DIST Yapsy-1.11.023.tar.gz 80595 SHA256 7b494e6cd62cc598d6d6f3be49dd45e9b1670b5d341627f60664d7002e4e0539 SHA512 98ce3925084119a7760ee5f8ed8904d6d4d39746918ff3eccfc64dd890a99aede0249dc3c97482fd53df441730083f790aa81d459ba4395e66f39248a5e14d79 WHIRLPOOL 91a15a51f0d4d64082202366a337ae91e433a426dca6f7c8b71470fb9f8354d36e1c45f5434a0c5a7474b2f3cfdc99c03a616402dbe1a4796519bb7a58be11a4
+DIST Yapsy-1.11.223.tar.gz 80783 SHA256 45bb39a72461913388d7f3e92ce33816e84fff59946c45e16796eb1fb1d5f2a6 SHA512 690d0ab78eafede5a75cf7b7bbcfce00b05c7b6f958980c3b67815bcaf848a8098b6e81afd1d95c5821fa4bb7affefab2cde208ff7c8ac7952615c8ddbafe305 WHIRLPOOL 05a3682f0c19a2c13ed97e9e17041f5bf7fd35a7928c4ff1bf27881a1575f1d1923c933ade7bb14569a732c6ddbcdffd3cba4ac546e8e4c1263f838876325082
diff --git a/dev-python/yapsy/metadata.xml b/dev-python/yapsy/metadata.xml
new file mode 100644
index 000000000000..9edc9cdc8ef5
--- /dev/null
+++ b/dev-python/yapsy/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>pinkbyte@gentoo.org</email>
+ <name>Sergey Popov</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">yapsy</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/yapsy/yapsy-1.10.423.ebuild b/dev-python/yapsy/yapsy-1.10.423.ebuild
new file mode 100644
index 000000000000..e7248ff40510
--- /dev/null
+++ b/dev-python/yapsy/yapsy-1.10.423.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+MY_P="Yapsy-${PV}"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A fat-free DIY Python plugin management toolkit"
+HOMEPAGE="http://yapsy.sourceforge.net/"
+SRC_URI="mirror://sourceforge/yapsy/${MY_P}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/yapsy/yapsy-1.11.023.ebuild b/dev-python/yapsy/yapsy-1.11.023.ebuild
new file mode 100644
index 000000000000..9d0a1741b229
--- /dev/null
+++ b/dev-python/yapsy/yapsy-1.11.023.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+MY_P="Yapsy-${PV}"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A fat-free DIY Python plugin management toolkit"
+HOMEPAGE="http://yapsy.sourceforge.net/"
+SRC_URI="mirror://sourceforge/yapsy/${MY_P}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+ # Disable erroneous test
+ sed -e 's:test_default_plugins_place_is_parent_dir:_&:' \
+ -i test/test_PluginFileLocator.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/yapsy/yapsy-1.11.223.ebuild b/dev-python/yapsy/yapsy-1.11.223.ebuild
new file mode 100644
index 000000000000..9d0a1741b229
--- /dev/null
+++ b/dev-python/yapsy/yapsy-1.11.223.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+MY_P="Yapsy-${PV}"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A fat-free DIY Python plugin management toolkit"
+HOMEPAGE="http://yapsy.sourceforge.net/"
+SRC_URI="mirror://sourceforge/yapsy/${MY_P}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+ # Disable erroneous test
+ sed -e 's:test_default_plugins_place_is_parent_dir:_&:' \
+ -i test/test_PluginFileLocator.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+ distutils-r1_python_install_all
+}