summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-28 13:53:52 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-28 15:12:49 +0100
commit820cc250751bd8e14cd80db11599e3a3f6b1f5b8 (patch)
treeeb3b7df44d6760dfc031dfb60653cc7a022b98f1 /dev-python/xonsh/files
parentdev-java/hessian: Clean up old. (diff)
downloadgentoo-820cc250751bd8e14cd80db11599e3a3f6b1f5b8.tar.gz
gentoo-820cc250751bd8e14cd80db11599e3a3f6b1f5b8.tar.bz2
gentoo-820cc250751bd8e14cd80db11599e3a3f6b1f5b8.zip
dev-python/xonsh: New package, ebuild written by me
Package-Manager: portage-2.2.25 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/xonsh/files')
-rw-r--r--dev-python/xonsh/files/xonsh-0.2.3-kernel-backport.patch47
-rw-r--r--dev-python/xonsh/files/xonsh-0.2.3-xonsh.bat-backport.patch22
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/xonsh/files/xonsh-0.2.3-kernel-backport.patch b/dev-python/xonsh/files/xonsh-0.2.3-kernel-backport.patch
new file mode 100644
index 000000000000..feed0d0af1c9
--- /dev/null
+++ b/dev-python/xonsh/files/xonsh-0.2.3-kernel-backport.patch
@@ -0,0 +1,47 @@
+From c650bc8a2b901a9e8d0c09f11f2482cfa6a1daee Mon Sep 17 00:00:00 2001
+From: Daniel Milde <daniel@milde.cz>
+Date: Sun, 8 Nov 2015 21:15:08 +0100
+Subject: [PATCH] installation of jupyter hook to given destination
+
+---
+ setup.py | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index 2996546..83984ba 100755
+--- a/setup.py
++++ b/setup.py
+@@ -19,7 +19,7 @@
+ HAVE_SETUPTOOLS = False
+
+ try:
+- from jupyter_client.kernelspec import install_kernel_spec
++ from jupyter_client.kernelspec import KernelSpecManager
+ HAVE_JUPYTER = True
+ except ImportError:
+ HAVE_JUPYTER = False
+@@ -49,7 +49,7 @@ def build_tables():
+ sys.path.pop(0)
+
+
+-def install_jupyter_hook():
++def install_jupyter_hook(root=None):
+ if not HAVE_JUPYTER:
+ print('Could not install Jupyter kernel spec, please install Jupyter/IPython.')
+ return
+@@ -73,13 +73,13 @@ def install_jupyter_hook():
+ with open(os.path.join(d, 'kernel.json'), 'w') as f:
+ json.dump(spec, f, sort_keys=True)
+ print('Installing Jupyter kernel spec...')
+- install_kernel_spec(d, 'xonsh', user=('--user' in sys.argv), replace=True)
++ KernelSpecManager().install_kernel_spec(d, 'xonsh', user=('--user' in sys.argv), replace=True, prefix=root)
+
+ class xinstall(install):
+ def run(self):
+ clean_tables()
+ build_tables()
+- install_jupyter_hook()
++ install_jupyter_hook(self.root if self.root else None)
+ install.run(self)
+
+
diff --git a/dev-python/xonsh/files/xonsh-0.2.3-xonsh.bat-backport.patch b/dev-python/xonsh/files/xonsh-0.2.3-xonsh.bat-backport.patch
new file mode 100644
index 000000000000..f938ad720a74
--- /dev/null
+++ b/dev-python/xonsh/files/xonsh-0.2.3-xonsh.bat-backport.patch
@@ -0,0 +1,22 @@
+From ed8b6ce37c76f62585a5cc86ac99194bf7115a84 Mon Sep 17 00:00:00 2001
+From: selepo <po.lenhoff@gmail.com>
+Date: Wed, 18 Nov 2015 18:50:17 +0100
+Subject: [PATCH] bugfix for issue 466 with xonsh.bat installed in non-windows
+
+---
+ setup.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index 0fb407b..7c10805 100755
+--- a/setup.py
++++ b/setup.py
+@@ -77,7 +77,7 @@ def main():
+ platforms='Cross Platform',
+ classifiers=['Programming Language :: Python :: 3'],
+ packages=['xonsh'],
+- scripts=['scripts/xonsh', 'scripts/xonsh.bat'],
++ scripts=['scripts/xonsh'] if 'win' not in sys.platform else ['scripts/xonsh.bat'],
+ cmdclass={'install': xinstall, 'sdist': xsdist},
+ )
+ if HAVE_SETUPTOOLS: