summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2020-06-06 18:29:26 +0200
committerPacho Ramos <pacho@gentoo.org>2020-06-06 18:29:37 +0200
commit1c0787a4fb9fa423567cf841e4792a3afb3c9bd1 (patch)
tree942c6376b4229b093934db893f1a745bf5969598 /dev-python/xlwt
parentapp-crypt/certbot-nginx: 1.4.0 stable amd64/x86 with cleanup (diff)
downloadgentoo-1c0787a4fb9fa423567cf841e4792a3afb3c9bd1.tar.gz
gentoo-1c0787a4fb9fa423567cf841e4792a3afb3c9bd1.tar.bz2
gentoo-1c0787a4fb9fa423567cf841e4792a3afb3c9bd1.zip
dev-python/xlwt: Support newer python
-r0 also supports newer python, adding them allow reverse deps still neeing py2 support to coexist with packages needing py > 3.8, while keeping -r1 py3 only for people not having py3 consumers. Also backport fixes from -r1 ebuild Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'dev-python/xlwt')
-rw-r--r--dev-python/xlwt/xlwt-1.3.0.ebuild36
1 files changed, 5 insertions, 31 deletions
diff --git a/dev-python/xlwt/xlwt-1.3.0.ebuild b/dev-python/xlwt/xlwt-1.3.0.ebuild
index f6160030c635..8c36c7f3763d 100644
--- a/dev-python/xlwt/xlwt-1.3.0.ebuild
+++ b/dev-python/xlwt/xlwt-1.3.0.ebuild
@@ -2,9 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
-
+PYTHON_COMPAT=( python2_7 python3_{6..9} )
inherit distutils-r1
DESCRIPTION="Python library to create spreadsheet files compatible with Excel"
@@ -14,37 +12,13 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 arm arm64 ppc ppc64 x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? (
- >=dev-python/sphinx-1.3.1[${PYTHON_USEDEP}]
- dev-python/pkginfo[${PYTHON_USEDEP}]
- )
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-# Prevent d'loading in the doc build
-PATCHES=( "${FILESDIR}/${PN}-1.3.0-no-intersphinx.patch" )
-
-python_prepare_all() {
- # Don't install documentation and examples in site-packages directories.
- sed -e "/package_data/d" -i setup.py || die
+IUSE="examples"
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- nosetests tests || die "tests failed under ${EPYTHON}}"
-}
+distutils_enable_sphinx docs \
+ dev-python/pkginfo
+distutils_enable_tests nose
python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
if use examples; then
dodoc -r examples
docompress -x /usr/share/doc/${PF}