summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2019-03-04 01:46:00 -0600
committerTim Harder <radhermit@gentoo.org>2019-03-04 02:28:09 -0600
commitdbde8ad7db4d20ccc3bb4a2392a4c6a4b494c6ba (patch)
treec6801fe8586424c8d38b24179ec469b269e92c89 /dev-python/xcffib
parentmedia-libs/exiftool: version bump to 11.29 (diff)
downloadgentoo-dbde8ad7db4d20ccc3bb4a2392a4c6a4b494c6ba.tar.gz
gentoo-dbde8ad7db4d20ccc3bb4a2392a4c6a4b494c6ba.tar.bz2
gentoo-dbde8ad7db4d20ccc3bb4a2392a4c6a4b494c6ba.zip
dev-python/xcffib: version bump to 0.7.0
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'dev-python/xcffib')
-rw-r--r--dev-python/xcffib/Manifest1
-rw-r--r--dev-python/xcffib/xcffib-0.7.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/xcffib/Manifest b/dev-python/xcffib/Manifest
index 09f49942d52c..e8a1c2cae5b7 100644
--- a/dev-python/xcffib/Manifest
+++ b/dev-python/xcffib/Manifest
@@ -1,3 +1,4 @@
DIST xcffib-0.4.0.tar.gz 74715 BLAKE2B e0e7d84cdb39a022225623fdefab7a5f8e6de2490b31b28b3a37dd8cff73286c5d418a6abde704a306d7a43ae1b4bebc8bf63aa27b0a055b21ed52bab8f6767e SHA512 ac144ffdfb559ae2ee8d4a23c937989ca4e28f913b2d27f1240725c8398ede1a7a010a0d861998151923d235d5e04799d8df8496c9ec8005a2286825dcd59bd7
DIST xcffib-0.5.1.tar.gz 81274 BLAKE2B 17e19d16a5d1b5699a10bc93c80327ba2d4c38d18c704b99f7e81a083ab8879f19dbb67b11cd0eebc47b8286c3f4413be089759bc49455674847593465dcc97e SHA512 ed13a43e301c6713c3831261bd94444d3961f805c39cc72dbe05f986eafb24e4f53f653045b84b57b4046a3ac763b20bd661298af5e6cc57978c57d68d2a0a39
DIST xcffib-0.6.0.tar.gz 84360 BLAKE2B 0947e1a20e9ad73f77e6cb000ed9fc8d70e45080edb74c5d25642c2d5ae388cc97461633e8cee1d7676557735b57b9cc1a3de459e54f96888cf7d19451d24c21 SHA512 de78b738f2a75e6569a0529d1fe2844b2cafe48623f25c20a9572ce881cb97325c3823dfe883a2e14bc93d01342f20c4ab561928312f65d0a67364fecb5c8ba5
+DIST xcffib-0.7.0.tar.gz 83895 BLAKE2B b2f8f2a4fcba20bfedc4e174d61900ea20bb8968bbdff73700ceeacd6c9fa36288bfcfd67a7d4206376b3b45e6e51481604e3ea3d6aa6d9ff68eaa49df25a414 SHA512 ad655e897eb08b898e396290c0b4b64a1e228b21fc5ed1fbcb3cc73bae466fa5255d539d864f1a9fdcb1396e73f60a981e00aab82efc343c7f83c8f62a6d31c5
diff --git a/dev-python/xcffib/xcffib-0.7.0.ebuild b/dev-python/xcffib/xcffib-0.7.0.ebuild
new file mode 100644
index 000000000000..35c18bb9fbe5
--- /dev/null
+++ b/dev-python/xcffib/xcffib-0.7.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A drop in replacement for xpyb, an XCB python binding"
+HOMEPAGE="https://github.com/tych0/xcffib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+
+COMMON_DEPEND="x11-libs/libxcb"
+RDEPEND="
+ $(python_gen_cond_dep '>=dev-python/cffi-1.1:=[${PYTHON_USEDEP}]' 'python*')
+ $(python_gen_cond_dep '>=virtual/pypy-2.6.0' pypy )
+ dev-python/six[${PYTHON_USEDEP}]
+ ${COMMON_DEPEND}"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${COMMON_DEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ x11-base/xorg-server[xvfb]
+ x11-apps/xeyes
+ )"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.4.2-test-imports.patch )
+
+python_test() {
+ nosetests -d -v || die
+}