summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-15 09:56:16 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-15 10:15:01 +0200
commitba07e6a7c4139e0e779242042f434100409a8593 (patch)
tree24744c27cde8f7401d4042f5a6818e536ee99ead /dev-python/wsgiproxy2
parentdev-python/pyquery: Enable py3.13 (diff)
downloadgentoo-ba07e6a7c4139e0e779242042f434100409a8593.tar.gz
gentoo-ba07e6a7c4139e0e779242042f434100409a8593.tar.bz2
gentoo-ba07e6a7c4139e0e779242042f434100409a8593.zip
dev-python/wsgiproxy2: Enable py3.13
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/wsgiproxy2')
-rw-r--r--dev-python/wsgiproxy2/wsgiproxy2-0.5.1-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/wsgiproxy2/wsgiproxy2-0.5.1-r2.ebuild b/dev-python/wsgiproxy2/wsgiproxy2-0.5.1-r2.ebuild
new file mode 100644
index 000000000000..16bd670092f7
--- /dev/null
+++ b/dev-python/wsgiproxy2/wsgiproxy2-0.5.1-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN="WSGIProxy2"
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="HTTP proxying tools for WSGI apps"
+HOMEPAGE="
+ https://github.com/gawel/WSGIProxy2/
+ https://pypi.org/project/WSGIProxy2/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ dev-python/webob[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/webtest-2.0.17[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs
+distutils_enable_tests unittest