summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-05 20:18:59 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-05 20:19:24 +0200
commitf69cc9a10199ebd0c253f7af6534ca8e309bca1c (patch)
tree2ef021cb2e685902e4885fb103e5b02bebd5f1f6 /dev-python/wheel
parentdev-python/pytest-fixture-config: Enable python3.10 (diff)
downloadgentoo-f69cc9a10199ebd0c253f7af6534ca8e309bca1c.tar.gz
gentoo-f69cc9a10199ebd0c253f7af6534ca8e309bca1c.tar.bz2
gentoo-f69cc9a10199ebd0c253f7af6534ca8e309bca1c.zip
dev-python/wheel: Enable python3.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/wheel')
-rw-r--r--dev-python/wheel/wheel-0.36.2.ebuild17
1 files changed, 2 insertions, 15 deletions
diff --git a/dev-python/wheel/wheel-0.36.2.ebuild b/dev-python/wheel/wheel-0.36.2.ebuild
index bbdaa700a3c2..bf0cf3f413cf 100644
--- a/dev-python/wheel/wheel-0.36.2.ebuild
+++ b/dev-python/wheel/wheel-0.36.2.ebuild
@@ -3,9 +3,7 @@
EAPI=7
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{7,8,9} pypy3 )
-
+PYTHON_COMPAT=( python3_{7..10} pypy3 )
inherit distutils-r1
DESCRIPTION="A built-package format for Python"
@@ -17,7 +15,7 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-distutils_enable_tests pytest
+distutils_enable_tests --install pytest
src_prepare() {
sed \
@@ -25,14 +23,3 @@ src_prepare() {
-i setup.cfg || die
distutils-r1_src_prepare
}
-
-python_test() {
- if ! python_is_python3; then
- # install fails due to unicode in paths
- ewarn "Testing is broken with py2.7, please test externally"
- return
- fi
-
- distutils_install_for_testing --via-root
- pytest -vv || die "Tests failed with ${EPYTHON}"
-}