summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-17 18:05:21 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-17 19:51:39 +0100
commit4ec2ee28f8bddb1a2051e70801d69f1cbfeaaea2 (patch)
tree0ec2259b8961be59de5d4d943371b0610110487d /dev-python/weasyprint
parentdev-python/python-neutronclient: Bump to 9.0.0 (diff)
downloadgentoo-4ec2ee28f8bddb1a2051e70801d69f1cbfeaaea2.tar.gz
gentoo-4ec2ee28f8bddb1a2051e70801d69f1cbfeaaea2.tar.bz2
gentoo-4ec2ee28f8bddb1a2051e70801d69f1cbfeaaea2.zip
dev-python/weasyprint: Bump to 58.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/weasyprint')
-rw-r--r--dev-python/weasyprint/Manifest1
-rw-r--r--dev-python/weasyprint/weasyprint-58.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/weasyprint/Manifest b/dev-python/weasyprint/Manifest
index 53e981d36eb2..88f7a4728641 100644
--- a/dev-python/weasyprint/Manifest
+++ b/dev-python/weasyprint/Manifest
@@ -1,2 +1,3 @@
DIST weasyprint-57.1.tar.gz 429652 BLAKE2B c94cc05f6c3b831d3214d7476e3fa799ff62d8fb575044a6f11172e650a87b1277e21fef40577bb01a1a778982a98e1a57801de708b3a3a26520b50aae8b43ac SHA512 0a130fba07d1d73eb4e9dcda27ab51ede45c440717f6fedb8d6aac09283244c366d36d85c2dac85995fbaebac21cf880a0cb684baaff3788af3eb6b4931c014b
DIST weasyprint-57.2.tar.gz 429120 BLAKE2B c97ba3fb3eec431a7de9a1a8a440290005de11b11d4abac4dd993a7d2fc4c14e64bdf13b8f8c12d4ba4f94b2049e0b05c3fb950c8b204f446323038c9c471451 SHA512 11b9469d37820439b1d0dad0117dd1c9649011c71aabb0e27008b303e5c851215ce9f0b271da9a74d614e54cb23f9c6036b6e094016b5688f6b700fb7444338f
+DIST weasyprint-58.0.tar.gz 433708 BLAKE2B 3ebb87eeeefad8d8a1a6a5d1ec54bef5cd153e8f837d19f87ce6ee891d4a20d41b38532972e9942e4d2123107491db42e0d690a95b8330510010ec2267c2948b SHA512 6c8258b1539ba7c6c692d0a54d0adb36a252d9f1a407df7934cf37202813e08e16e97d2f70a322a2787e2ab64545f4a4fd745fe4771b9383f520b9fc8d51db28
diff --git a/dev-python/weasyprint/weasyprint-58.0.ebuild b/dev-python/weasyprint/weasyprint-58.0.ebuild
new file mode 100644
index 000000000000..c9362f1c7799
--- /dev/null
+++ b/dev-python/weasyprint/weasyprint-58.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Visual rendering engine for HTML and CSS that can export to PDF"
+HOMEPAGE="
+ https://weasyprint.org/
+ https://github.com/Kozea/WeasyPrint/
+ https://pypi.org/project/weasyprint/
+"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/cffi-0.6:=[${PYTHON_USEDEP}]
+ >=dev-python/cssselect2-0.1[${PYTHON_USEDEP}]
+ >=dev-python/fonttools-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/html5lib-1.1[${PYTHON_USEDEP}]
+ >=dev-python/pillow-4.0.0[jpeg,jpeg2k,${PYTHON_USEDEP}]
+ >=dev-python/pydyf-0.5.0[${PYTHON_USEDEP}]
+ >=dev-python/pyphen-0.9.1[${PYTHON_USEDEP}]
+ >=dev-python/tinycss2-1.0.0[${PYTHON_USEDEP}]
+ media-fonts/dejavu
+ x11-libs/pango
+"
+
+BDEPEND="
+ test? (
+ || (
+ >=app-text/ghostscript-gpl-9.56.1-r3
+ <app-text/ghostscript-gpl-9.56.0
+ )
+ media-fonts/ahem
+ )
+"
+
+distutils_enable_tests pytest