summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-08-17 18:30:48 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-09-15 11:09:18 +0300
commit54ec1696f459c50f06df04029f18a660435439a0 (patch)
tree56f7ea25bff7ff03fa06040b3619c3e29a2d7bd4 /dev-python/vncdotool/vncdotool-1.0.0.ebuild
parentdev-python/pyscreenshot: Python screenshot library (diff)
downloadgentoo-54ec1696f459c50f06df04029f18a660435439a0.tar.gz
gentoo-54ec1696f459c50f06df04029f18a660435439a0.tar.bz2
gentoo-54ec1696f459c50f06df04029f18a660435439a0.zip
dev-python/vncdotool: Command line VNC client
Package-Manager: Portage-3.0.2, Repoman-2.3.23 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python/vncdotool/vncdotool-1.0.0.ebuild')
-rw-r--r--dev-python/vncdotool/vncdotool-1.0.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/vncdotool/vncdotool-1.0.0.ebuild b/dev-python/vncdotool/vncdotool-1.0.0.ebuild
new file mode 100644
index 000000000000..586c2cf93a15
--- /dev/null
+++ b/dev-python/vncdotool/vncdotool-1.0.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Command line VNC client"
+HOMEPAGE="https://github.com/sibson/vncdotool"
+SRC_URI="https://github.com/sibson/vncdotool/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# No clue why this happens:
+# pexpect.exceptions.ExceptionPexpect: The command was not found or was not executable: vncev.
+RESTRICT="test"
+
+BDEPEND="test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pluggy[${PYTHON_USEDEP}]
+ dev-python/ptyprocess[${PYTHON_USEDEP}]
+ dev-python/py[${PYTHON_USEDEP}]
+ dev-python/tox[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+)"
+
+DEPEND="
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/twisted[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs