summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-31 08:02:43 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-31 09:13:09 +0200
commite7477b3e434f85083dd881f51aa0b3bf4aab5e66 (patch)
treec5c44be822156955681a8d296faef9c5cef218c3 /dev-python/vcrpy
parentdev-python/moto: Bump to 4.1.14 (diff)
downloadgentoo-e7477b3e434f85083dd881f51aa0b3bf4aab5e66.tar.gz
gentoo-e7477b3e434f85083dd881f51aa0b3bf4aab5e66.tar.bz2
gentoo-e7477b3e434f85083dd881f51aa0b3bf4aab5e66.zip
dev-python/vcrpy: Bump to 5.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/vcrpy')
-rw-r--r--dev-python/vcrpy/Manifest1
-rw-r--r--dev-python/vcrpy/vcrpy-5.1.0.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/vcrpy/Manifest b/dev-python/vcrpy/Manifest
index 28a18dc8e9dd..6073d2fc4f6e 100644
--- a/dev-python/vcrpy/Manifest
+++ b/dev-python/vcrpy/Manifest
@@ -1 +1,2 @@
DIST vcrpy-5.0.0.gh.tar.gz 336090 BLAKE2B f8460956456c332be24736153326651a319f3c25f8a38aab27f5a39ff9e312d0643ce702951cd906e735cbaa7c469cc948ce7599a37c767ef379fa10ff5ff69e SHA512 dcf1564b9e8640fe4998d13f4a74a892c6ac152bade6db2b040577e7a3b5e83b87f02a3ea93d58d3102ec6bbd6e452f5bd85c03273fb67fd6800caf87b5f3c6b
+DIST vcrpy-5.1.0.gh.tar.gz 337183 BLAKE2B 76805db7c034fe4f6e0d6fb18340ad24a25a28ece4576d97958d689e46667a8ab2fb6cdc8186f635a7c4f4833d4ea541573bf6c5e0f775f842e60683336ad87e SHA512 dfb2e02027ed2e37f4c2201b410847cf1f03b1999853e3f838e49abf1e93641d58addb18f6144c484f9d4618693b9a99d73dc7fb55eb1de2c383109e054e3713
diff --git a/dev-python/vcrpy/vcrpy-5.1.0.ebuild b/dev-python/vcrpy/vcrpy-5.1.0.ebuild
new file mode 100644
index 000000000000..e3d29e7c02be
--- /dev/null
+++ b/dev-python/vcrpy/vcrpy-5.1.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Automatically mock your HTTP interactions to simplify and speed up testing"
+HOMEPAGE="
+ https://github.com/kevin1024/vcrpy/
+ https://pypi.org/project/vcrpy/
+"
+SRC_URI="
+ https://github.com/kevin1024/vcrpy/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/httplib2-0.9.1[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.16.2[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ dev-python/wrapt[${PYTHON_USEDEP}]
+ dev-python/yarl[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-httpbin[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # these tests are failing with recent dev-python/werkzeug; losely related:
+ # https://github.com/kevin1024/vcrpy/issues/645
+ tests/integration/test_record_mode.py::test_new_episodes_record_mode_two_times
+ tests/integration/test_urllib2.py::test_random_body
+ tests/integration/test_urllib2.py::test_multiple_requests
+ # broken in general
+ tests/integration/test_boto.py
+ # Internet
+ tests/integration/test_tornado.py
+ # broken by simplejson, doesn't seem important
+ # https://github.com/kevin1024/vcrpy/issues/751
+ tests/unit/test_serialize.py::test_serialize_binary_request
+ )
+
+ local -x REQUESTS_CA_BUNDLE=$("${EPYTHON}" -m pytest_httpbin.certs)
+ epytest -m 'not online'
+}