summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-01-23 20:18:20 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2024-01-23 20:18:40 +0200
commit1de5be4c84e843accf56d3bf62c5de15a55c6818 (patch)
tree4e42dc5979b5a486f191dc94c3589821dfce5e86 /dev-python/vcrpy
parentdev-python/hypothesis: add 6.96.4 (diff)
downloadgentoo-1de5be4c84e843accf56d3bf62c5de15a55c6818.tar.gz
gentoo-1de5be4c84e843accf56d3bf62c5de15a55c6818.tar.bz2
gentoo-1de5be4c84e843accf56d3bf62c5de15a55c6818.zip
dev-python/vcrpy: add 6.0.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/vcrpy')
-rw-r--r--dev-python/vcrpy/Manifest1
-rw-r--r--dev-python/vcrpy/vcrpy-6.0.0.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/vcrpy/Manifest b/dev-python/vcrpy/Manifest
index 28c3b0fdda1f..69200ba6af88 100644
--- a/dev-python/vcrpy/Manifest
+++ b/dev-python/vcrpy/Manifest
@@ -1 +1,2 @@
DIST vcrpy-5.1.0.gh.tar.gz 337183 BLAKE2B 76805db7c034fe4f6e0d6fb18340ad24a25a28ece4576d97958d689e46667a8ab2fb6cdc8186f635a7c4f4833d4ea541573bf6c5e0f775f842e60683336ad87e SHA512 dfb2e02027ed2e37f4c2201b410847cf1f03b1999853e3f838e49abf1e93641d58addb18f6144c484f9d4618693b9a99d73dc7fb55eb1de2c383109e054e3713
+DIST vcrpy-6.0.0.gh.tar.gz 337408 BLAKE2B b335b3e89b759b111e34ed26753d528ce0b83bd6e408b35bb60371ada1d773e8e6e690991d468ae63fb61b799c2f79f2677043bc8a56a3b95fec477ee7c679e3 SHA512 d10c8a01843b8390c16fda26b0266d8b89d9d95978f99127f0c261e94dab6b7c358522fa6d059063e3c194885e8be46ef206bdfc1252511840058dd5df4cf11d
diff --git a/dev-python/vcrpy/vcrpy-6.0.0.ebuild b/dev-python/vcrpy/vcrpy-6.0.0.ebuild
new file mode 100644
index 000000000000..212c7bfe7855
--- /dev/null
+++ b/dev-python/vcrpy/vcrpy-6.0.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Automatically mock your HTTP interactions to simplify and speed up testing"
+HOMEPAGE="
+ https://github.com/kevin1024/vcrpy/
+ https://pypi.org/project/vcrpy/
+"
+SRC_URI="
+ https://github.com/kevin1024/vcrpy/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/httplib2-0.9.1[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.16.2[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ dev-python/wrapt[${PYTHON_USEDEP}]
+ dev-python/yarl[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-httpbin[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # these tests are failing with recent dev-python/werkzeug; losely related:
+ # https://github.com/kevin1024/vcrpy/issues/645
+ tests/integration/test_record_mode.py::test_new_episodes_record_mode_two_times
+ tests/integration/test_urllib2.py::test_random_body
+ tests/integration/test_urllib2.py::test_multiple_requests
+ # Internet
+ "tests/integration/test_urllib3.py::test_post[https]"
+ )
+
+ local EPYTEST_IGNORE=(
+ # requires boto3
+ tests/integration/test_boto3.py
+ # Internet
+ tests/integration/test_tornado.py
+ tests/integration/test_aiohttp.py
+ )
+
+ local -x REQUESTS_CA_BUNDLE=$("${EPYTHON}" -m pytest_httpbin.certs)
+ epytest -m 'not online'
+}