summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-07 03:16:32 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-07 03:35:11 +0200
commit7caa918f96619eced787c9078b9c79e744d12b32 (patch)
treefb34788edadfade9b1cc58edc5d77b1acb04de21 /dev-python/uv
parentapp-doc/python-docs: Bump to 3.12.4 (diff)
downloadgentoo-7caa918f96619eced787c9078b9c79e744d12b32.tar.gz
gentoo-7caa918f96619eced787c9078b9c79e744d12b32.tar.bz2
gentoo-7caa918f96619eced787c9078b9c79e744d12b32.zip
dev-python/uv: Bump to 0.2.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/uv')
-rw-r--r--dev-python/uv/Manifest2
-rw-r--r--dev-python/uv/uv-0.2.9.ebuild110
2 files changed, 112 insertions, 0 deletions
diff --git a/dev-python/uv/Manifest b/dev-python/uv/Manifest
index 9bce275dd236..87860dc67f53 100644
--- a/dev-python/uv/Manifest
+++ b/dev-python/uv/Manifest
@@ -6,3 +6,5 @@ DIST uv-0.1.24-crates.tar.xz 64420840 BLAKE2B 7324461092a07c86aadaddf051aaa7454e
DIST uv-0.1.24.gh.tar.gz 899637 BLAKE2B fab26ba9934fc5f586505b5ac1fa386c11f07e51ca2bb2a79f46d5dec9475ba8d75ad8587223d5149df5f2a225146d020a49b7ff81ed26b949cff55892738c2d SHA512 520b47a096b50fce9e7b7af5bca203df9bf4c2d0aafbe28a3dcfe0592d8ddcaa7b58d52300c67454f6aeecfd196f1592be18e45c95b7c67257361917cdb0154d
DIST uv-0.2.8-crates.tar.xz 49233792 BLAKE2B 9ba3816b627b02079ca64c29764c4484a2ca617f8ea5426f0cbae367c5e2647f5b0a3927408e3352645358a1de5513e66e3cec38955920435d1165178e348196 SHA512 b2474f3445745f4351774c597100bafc471db30d9078c4891b426ef299b0b5b30185fb5a2398cc4cf3851e2bdab1fc2c361a990d80eddbd9100314102583cc2a
DIST uv-0.2.8.gh.tar.gz 1139645 BLAKE2B 6a3ce5cf2b9978e0b292c543e81b17df476f410a832524b9d036981a4fcb8ab67f1769e9f975599c7df950b9de802a8147ce209fb5f7c7ea66b4d0197843e6e0 SHA512 e0c6e9e5274095b2315604fd9ae4742c931cd64a893a832142c2ee54be2b8b32fa28a72eb16ef7ef26c7ad3d37ba8428dca62ad653977e98a5c1f029b9260201
+DIST uv-0.2.9-crates.tar.xz 49233792 BLAKE2B 9ba3816b627b02079ca64c29764c4484a2ca617f8ea5426f0cbae367c5e2647f5b0a3927408e3352645358a1de5513e66e3cec38955920435d1165178e348196 SHA512 b2474f3445745f4351774c597100bafc471db30d9078c4891b426ef299b0b5b30185fb5a2398cc4cf3851e2bdab1fc2c361a990d80eddbd9100314102583cc2a
+DIST uv-0.2.9.gh.tar.gz 1147989 BLAKE2B 283bddd99defa92c71da8bad75a9d943585f2feb862fd5764fc9c4d529752506bb79e4fae5d3db532e92a961eaac7554fb679ceaeca6b224c5264a12191586a3 SHA512 bae1ad801ca2dc1d79dfd3b2ce166a97aaab048566059c3ccdbd794bb94876ff4ada45f5a86a22dd92435b9fe4b0b099b6b83132eda2c2fd98d9ceba65c3b66c
diff --git a/dev-python/uv/uv-0.2.9.ebuild b/dev-python/uv/uv-0.2.9.ebuild
new file mode 100644
index 000000000000..fe1601abeb5d
--- /dev/null
+++ b/dev-python/uv/uv-0.2.9.ebuild
@@ -0,0 +1,110 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CRATES="
+"
+
+declare -A GIT_CRATES=(
+ [async_zip]='https://github.com/charliermarsh/rs-async-zip;1dcb40cfe1bf5325a6fd4bfcf9894db40241f585;rs-async-zip-%commit%'
+ [pubgrub]='https://github.com/astral-sh/pubgrub;a68cbd1a26e43986a31563e1d127e83bafca3a0c;pubgrub-%commit%'
+)
+
+# workaround faulty assumptions that 3.12 is the newest Python installed
+PYTHON_COMPAT=( python3_12 )
+
+inherit cargo check-reqs python-any-r1
+
+CRATE_P=${P}
+DESCRIPTION="A Python package installer and resolver, written in Rust"
+HOMEPAGE="
+ https://github.com/astral-sh/uv/
+ https://pypi.org/project/uv/
+"
+# pypi sdist misses scripts/, needed for tests
+SRC_URI="
+ https://github.com/astral-sh/uv/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ ${CARGO_CRATE_URIS}
+"
+if [[ ${PKGBUMPING} != ${PVR} ]]; then
+ SRC_URI+="
+ https://dev.gentoo.org/~mgorny/dist/${CRATE_P}-crates.tar.xz
+ "
+fi
+
+# most of the code
+LICENSE="|| ( Apache-2.0 MIT )"
+# crates/pep508-rs is || ( Apache-2.0 BSD-2 ) which is covered below
+# Dependent crate licenses
+LICENSE+="
+ 0BSD Apache-2.0 Apache-2.0-with-LLVM-exceptions BSD-2 BSD ISC MIT
+ MPL-2.0 Unicode-DFS-2016
+"
+# ring crate
+LICENSE+=" openssl"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+IUSE="test"
+RESTRICT="test"
+PROPERTIES="test_network"
+
+DEPEND="
+ dev-libs/libgit2:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ >=virtual/rust-1.77
+ test? (
+ dev-lang/python:3.8
+ dev-lang/python:3.9
+ dev-lang/python:3.10
+ dev-lang/python:3.11
+ dev-lang/python:3.12
+ )
+"
+
+QA_FLAGS_IGNORED="usr/bin/.*"
+
+check_space() {
+ local CHECKREQS_DISK_BUILD=3G
+ use debug && CHECKREQS_DISK_BUILD=9G
+ check-reqs_pkg_setup
+}
+
+pkg_pretend() {
+ check_space
+}
+
+pkg_setup() {
+ check_space
+ python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ # https://github.com/vorot93/tokio-tar/pull/23
+ # (fortunately uv already depends on portable-atomic, so we don't
+ # have to fight Cargo.lock)
+ cd "${WORKDIR}/cargo_home/gentoo/tokio-tar-0.3.1" || die
+ eapply "${FILESDIR}/tokio-tar-0.3.1-ppc.patch"
+}
+
+src_compile() {
+ cd crates/uv || die
+ cargo_src_compile
+}
+
+src_test() {
+ cd crates/uv || die
+ cargo_src_test --no-fail-fast
+}
+
+src_install() {
+ cd crates/uv || die
+ cargo_src_install
+}