summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-01-27 15:37:56 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2023-01-27 17:47:19 +0200
commit28ce4d68f16bd0961c95e0bfa1b0cedae084169d (patch)
tree54ac2e454e30c332b8c68de396148c69bc6f9997 /dev-python/urwid
parentdev-python/mysqlclient: enable py3.11 (diff)
downloadgentoo-28ce4d68f16bd0961c95e0bfa1b0cedae084169d.tar.gz
gentoo-28ce4d68f16bd0961c95e0bfa1b0cedae084169d.tar.bz2
gentoo-28ce4d68f16bd0961c95e0bfa1b0cedae084169d.zip
dev-python/urwid: enable py3.11
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/urwid')
-rw-r--r--dev-python/urwid/files/urwid-2.1.2-fix-py3.11.patch26
-rw-r--r--dev-python/urwid/urwid-2.1.2-r1.ebuild7
2 files changed, 32 insertions, 1 deletions
diff --git a/dev-python/urwid/files/urwid-2.1.2-fix-py3.11.patch b/dev-python/urwid/files/urwid-2.1.2-fix-py3.11.patch
new file mode 100644
index 000000000000..dd60b8a220b9
--- /dev/null
+++ b/dev-python/urwid/files/urwid-2.1.2-fix-py3.11.patch
@@ -0,0 +1,26 @@
+https://github.com/urwid/urwid/pull/517
+From: =?UTF-8?q?Robert=20Sch=C3=BCtz?= <mail@dotlambda.de>
+Date: Fri, 20 Jan 2023 11:37:15 -0800
+Subject: [PATCH] make tests compatible with Python 3.11
+
+--- a/urwid/tests/test_event_loops.py
++++ b/urwid/tests/test_event_loops.py
+@@ -201,15 +201,14 @@ def test_error(self):
+ evl.alarm(0.5, lambda: 1 / 0) # Simulate error in event loop
+ self.assertRaises(ZeroDivisionError, evl.run)
+
+- def test_coroutine_error(self):
++ async def test_coroutine_error(self):
+ evl = self.evl
+
+- @asyncio.coroutine
+- def error_coro():
++ async def error_coro():
+ result = 1 / 0 # Simulate error in coroutine
+ yield result
+
+- asyncio.ensure_future(error_coro())
++ asyncio.ensure_future(await error_coro())
+ self.assertRaises(ZeroDivisionError, evl.run)
+
+
diff --git a/dev-python/urwid/urwid-2.1.2-r1.ebuild b/dev-python/urwid/urwid-2.1.2-r1.ebuild
index 9914a472ab5f..b0934f8622e6 100644
--- a/dev-python/urwid/urwid-2.1.2-r1.ebuild
+++ b/dev-python/urwid/urwid-2.1.2-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..10} )
+PYTHON_COMPAT=( python3_{9..11} )
PYTHON_REQ_USE="ncurses"
inherit distutils-r1 optfeature
@@ -24,6 +24,11 @@ IUSE="examples"
distutils_enable_sphinx docs
distutils_enable_tests setup.py
+PATCHES=(
+ # https://github.com/urwid/urwid/pull/517
+ "${FILESDIR}/${P}-fix-py3.11.patch"
+)
+
src_prepare() {
# optional tests broken by modern tornado versions
sed -e 's:import tornado:&_broken:' \