summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-01-14 04:32:03 +0100
committerMichał Górny <mgorny@gentoo.org>2020-01-14 04:53:21 +0100
commit61c57b6c3bf52f8d9175f4fdf374bdd4935f67af (patch)
treed0c1d6ac28821a7b6ea87323aea7422a035fcc76 /dev-python/typed-ast
parentdev-python/typed-ast: Remove redundant versions (diff)
downloadgentoo-61c57b6c3bf52f8d9175f4fdf374bdd4935f67af.tar.gz
gentoo-61c57b6c3bf52f8d9175f4fdf374bdd4935f67af.tar.bz2
gentoo-61c57b6c3bf52f8d9175f4fdf374bdd4935f67af.zip
dev-python/typed-ast: Bump to 1.4.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/typed-ast')
-rw-r--r--dev-python/typed-ast/Manifest1
-rw-r--r--dev-python/typed-ast/typed-ast-1.4.1.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/typed-ast/Manifest b/dev-python/typed-ast/Manifest
index 9e651ce8c49f..3c59673bf7d9 100644
--- a/dev-python/typed-ast/Manifest
+++ b/dev-python/typed-ast/Manifest
@@ -1 +1,2 @@
DIST typed_ast-1.4.0.tar.gz 206620 BLAKE2B 59d3ed516b63643e37d9530dcb82670dd0e36f436650880f9fb304d081c3a72ecd494646dbf8f62fe95d2e70742390a5be711bcb803f1f0b6524dec1bf43c8c3 SHA512 b74e7fc51cde16439eae7cf41f0bdb95b5998362eccb73cf736f343cdab64daab63bc0f95f05a4911b229761749bdd31ac83423b58f2f3e1e1dadc7e6015bc1c
+DIST typed_ast-1.4.1.tar.gz 208587 BLAKE2B db874caf459cb73345305051a7c4e97244e92b28e94e82f59b38bb91b7c6c69a2531a81c84d483eca8d641bc947f6aa1b98ba59cd880f7560fbdec55bce41787 SHA512 a3154fe723aeadf998694aba0faf516e5b9abb876e4c7d91843b3694474ff6911b3e77a6cb7366cfa8e5a573b331906b6a0b134b25627aaba0dcbe92c4e25590
diff --git a/dev-python/typed-ast/typed-ast-1.4.1.ebuild b/dev-python/typed-ast/typed-ast-1.4.1.ebuild
new file mode 100644
index 000000000000..9e391ae03a11
--- /dev/null
+++ b/dev-python/typed-ast/typed-ast-1.4.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="Python typed-ast backported"
+HOMEPAGE="https://pypi.org/project/typed-ast/ https://github.com/python/typed_ast"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN/-/_}/${P/-/_}.tar.gz"
+
+LICENSE="Apache-2.0 MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${P/-/_}"
+
+distutils_enable_tests pytest