summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-30 05:33:25 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-30 05:33:25 +0200
commitf0894a35dabf08eb400d23700bf897d02481c580 (patch)
tree86f9ab335f8039320c26b886feb47508c4c5805c /dev-python/trove-classifiers
parentdev-python/ipython: Bump to 8.13.1 (diff)
downloadgentoo-f0894a35dabf08eb400d23700bf897d02481c580.tar.gz
gentoo-f0894a35dabf08eb400d23700bf897d02481c580.tar.bz2
gentoo-f0894a35dabf08eb400d23700bf897d02481c580.zip
dev-python/trove-classifiers: Bump to 2023.4.29
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/trove-classifiers')
-rw-r--r--dev-python/trove-classifiers/Manifest1
-rw-r--r--dev-python/trove-classifiers/trove-classifiers-2023.4.29.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/trove-classifiers/Manifest b/dev-python/trove-classifiers/Manifest
index e85f74c253b5..c7258c75ff96 100644
--- a/dev-python/trove-classifiers/Manifest
+++ b/dev-python/trove-classifiers/Manifest
@@ -3,3 +3,4 @@ DIST trove-classifiers-2023.4.18.tar.gz 15808 BLAKE2B 72b6b7efa53d40859464f5b055
DIST trove-classifiers-2023.4.20.tar.gz 15814 BLAKE2B 5f28f08143f9a08f3a731133b8eac32276b6d5ea582b7e4f6700a481b87da6ffce4cbf0ca6e9a2a70713ad1bdecec27427e60c0751dd2f5ecaace21f68b74221 SHA512 cc046e1cc7d4ff10829b3f6ff9ccedd1f2143bc27c84232dabc79368d78648266166f96fbcc50c8690bef47d28d1920c9855fcf1483620b003b7366b3ba798bc
DIST trove-classifiers-2023.4.22.tar.gz 15816 BLAKE2B 9f254f0116fcd87f840ac1760f46073b9404bfe7c2b8b37708566f8724895881d4ffcfda7319ac1eb21514405435ae8633e276d7ca6dfa1be2432aca5b233367 SHA512 2e253e3ef716da2f677b3f463abd4ab625a4be700e266c2feb595f5f76867880c48954f1d7b79a0acdac30466530fbd84dfb49f740830a90616df3acd247cb27
DIST trove-classifiers-2023.4.25.tar.gz 15842 BLAKE2B 07956b0316f7e6d51910c19ca12ff701f337f74bfaee4d80adf1a26cbfd3e405ba70ed1985ba282180f5c5a6a71eddb58a6e976153989e13c98bd78f33598511 SHA512 0010eff8fa895098b51799ef219e790a73001a7c7a04b4907f546e57099feace79b21c61712c7bda4a4c08b0a865949e71b298fb3d8ffb32772cb06b59191f2a
+DIST trove-classifiers-2023.4.29.tar.gz 15824 BLAKE2B 5a1dc9494f38fc20d54361976ba3abf873128455311f518f195878fad1d5f41e1e9e50f0ea75e3b534ef9d07e8307370e74e3cdb9a47f4d4a36f97a3b30ce556 SHA512 132f723273355ce8dbcbf544b4d0809f1e1f2e390289f3e862bf471aa28b95c0cd67f4c440c412d579be7c4ffe30769f8cbb0ec4f224a73e6deb7b1a8fe4844a
diff --git a/dev-python/trove-classifiers/trove-classifiers-2023.4.29.ebuild b/dev-python/trove-classifiers/trove-classifiers-2023.4.29.ebuild
new file mode 100644
index 000000000000..e404744e2dba
--- /dev/null
+++ b/dev-python/trove-classifiers/trove-classifiers-2023.4.29.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Canonical source for classifiers on PyPI (pypi.org)"
+HOMEPAGE="
+ https://github.com/pypa/trove-classifiers/
+ https://pypi.org/project/trove-classifiers/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ dev-python/calver[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest
+ "${EPYTHON}" -m tests.lib || die
+}