summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Byrne <salah.coronya@gmail.com>2022-08-21 18:06:02 -0500
committerJoonas Niilola <juippis@gentoo.org>2022-09-05 16:07:43 +0300
commit4d8d5fed759811fee93af913cd27f427e5e60508 (patch)
treece8460b8f2ccc92e78ea33c1aa831c613c574f02 /dev-python/tpm2-pytss
parentsys-kernel/gentoo-sources: add 5.19.7 (diff)
downloadgentoo-4d8d5fed759811fee93af913cd27f427e5e60508.tar.gz
gentoo-4d8d5fed759811fee93af913cd27f427e5e60508.tar.bz2
gentoo-4d8d5fed759811fee93af913cd27f427e5e60508.zip
dev-python/tpm2-pytss: add 1.2.0
Signed-off-by: Christopher Byrne <salah.coronya@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python/tpm2-pytss')
-rw-r--r--dev-python/tpm2-pytss/Manifest1
-rw-r--r--dev-python/tpm2-pytss/tpm2-pytss-1.2.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/tpm2-pytss/Manifest b/dev-python/tpm2-pytss/Manifest
index e64e0fbfbc18..4f8086d66abe 100644
--- a/dev-python/tpm2-pytss/Manifest
+++ b/dev-python/tpm2-pytss/Manifest
@@ -1 +1,2 @@
DIST tpm2-pytss-1.1.0.tar.gz 162559 BLAKE2B 2c9b34c323b96b3a8ded82a04accac9647d7f0b1cf05d269ed4bdf225d785fd8454dee82f054a5085f9d49d0feabacc8c5b72a7ee8af7bc9da8473d5689501b5 SHA512 71da9e005a3f645c0528a96bb96bafde9c262c5778646a19841af6323edaf889ede7267317ea96b7d44c7901d7bea04ca15fd1b5c86d61d33e49b34f5d0e2e94
+DIST tpm2-pytss-1.2.0.tar.gz 178555 BLAKE2B 782f7d8194d2a9395213f39e5a17414ae2ab49f961b01c496fd54803a43f6846434a1d69a3993d16b6b51c2578f6f5e1a0d883be791cf6fb29ae23012b2090cf SHA512 688223d05a2ed5f3a5aeec47c77a02c10d40d4f23a97622e76acbf8f86b14ac2a92482869c5e04de395edb96b1e1b142c5ff53c7dbc97673ead531e4d6138184
diff --git a/dev-python/tpm2-pytss/tpm2-pytss-1.2.0.ebuild b/dev-python/tpm2-pytss/tpm2-pytss-1.2.0.ebuild
new file mode 100644
index 000000000000..b805c0e64531
--- /dev/null
+++ b/dev-python/tpm2-pytss/tpm2-pytss-1.2.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for TSS"
+HOMEPAGE="
+ https://pypi.org/project/tpm2-pytss
+ https://github.com/tpm2-software/tpm2-pytss
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="+fapi test"
+
+RDEPEND="app-crypt/tpm2-tss:=[fapi=]
+ fapi? ( >=app-crypt/tpm2-tss-3.0.3:= )
+ dev-python/cffi[${PYTHON_USEDEP}]
+ dev-python/asn1crypto[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/pycparser[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]"
+
+DEPEND="${RDEPEND}
+ test? ( app-crypt/swtpm )"
+
+BDEPEND="dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/pkgconfig[${PYTHON_USEDEP}]"
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+distutils_enable_tests pytest