summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-14 16:37:16 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-14 16:55:20 +0200
commit2ecd63df8e6b47e63a92a5d4711674b3a689b9b4 (patch)
tree61d43305011ec31b5cf073dab3a625a6345162b9 /dev-python/time-machine/time-machine-2.12.0.ebuild
parentdev-python/werkzeug: Bump to 2.3.7 (diff)
downloadgentoo-2ecd63df8e6b47e63a92a5d4711674b3a689b9b4.tar.gz
gentoo-2ecd63df8e6b47e63a92a5d4711674b3a689b9b4.tar.bz2
gentoo-2ecd63df8e6b47e63a92a5d4711674b3a689b9b4.zip
dev-python/time-machine: Bump to 2.12.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/time-machine/time-machine-2.12.0.ebuild')
-rw-r--r--dev-python/time-machine/time-machine-2.12.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/time-machine/time-machine-2.12.0.ebuild b/dev-python/time-machine/time-machine-2.12.0.ebuild
new file mode 100644
index 000000000000..d6f96f71fc73
--- /dev/null
+++ b/dev-python/time-machine/time-machine-2.12.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Travel through time in your tests"
+HOMEPAGE="
+ https://github.com/adamchainz/time-machine/
+ https://pypi.org/project/time-machine/
+"
+SRC_URI="
+ https://github.com/adamchainz/time-machine/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest