summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-10 08:28:15 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-10 08:58:08 +0100
commit4135cb80b62f835b39fa809d6c9620e4226a6c58 (patch)
tree08388e98210e596606a010c0c10545c04d5ba9aa /dev-python/tifffile
parentdev-python/nbconvert: Bump to 6.4.2 (diff)
downloadgentoo-4135cb80b62f835b39fa809d6c9620e4226a6c58.tar.gz
gentoo-4135cb80b62f835b39fa809d6c9620e4226a6c58.tar.bz2
gentoo-4135cb80b62f835b39fa809d6c9620e4226a6c58.zip
dev-python/tifffile: Bump to 2022.2.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tifffile')
-rw-r--r--dev-python/tifffile/Manifest1
-rw-r--r--dev-python/tifffile/tifffile-2022.2.9.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/tifffile/Manifest b/dev-python/tifffile/Manifest
index 073a0a379e59..1643bfd5a4aa 100644
--- a/dev-python/tifffile/Manifest
+++ b/dev-python/tifffile/Manifest
@@ -1,2 +1,3 @@
DIST tifffile-2021.11.2.gh.tar.gz 261953 BLAKE2B 039e25b173d2074b5a869394bb40cd62410b34c8a86bf047cd203aad6ab0e3217d0f4006bb092840acb314598c73619e48c66daa04c81f9965ca46b81f055d6e SHA512 5bd3340af027547bf07d78523c5c2abcecb428606d72daa446c7f3cd06f7c8da015e20cd0f4ebeb1e9a49ce0aaf6c2840170dad7a8a28e403716d4bdb1ba2238
DIST tifffile-2022.2.2.gh.tar.gz 263421 BLAKE2B d0360d0cbaaaa53425624c81e6cb52fa2fdff96582058a71649361ebc9151ea732652051ad9086710c20a79a88db9a4e8092167142052a3d0b0106b5bbe378fe SHA512 591b61eba84c421420e53e185f27d7f17bc6ae1cf379259e4d5ddfcfa52ed991560d907c5a63c5fea50773f3d497202433a9570a56aa2bc392fd4ba712d94988
+DIST tifffile-2022.2.9.gh.tar.gz 264011 BLAKE2B 529eee731cf6c7b9fe925dffb70117517d560bdb0fe991f86d5a32d6167aa3c7f265466f72e51531b45e86d466d749d1880c1b6beadd498a999e0e59e174a08f SHA512 642a93b2f809d70faaae7265b80aaaf7d7c3190b96aa0e3062f6c708e6484e3338ec319163dc9eb3156553377d4a4152cbf908c7c2df406d1b58b289ea95bdc0
diff --git a/dev-python/tifffile/tifffile-2022.2.9.ebuild b/dev-python/tifffile/tifffile-2022.2.9.ebuild
new file mode 100644
index 000000000000..bcfdee9f5d5f
--- /dev/null
+++ b/dev-python/tifffile/tifffile-2022.2.9.ebuild
@@ -0,0 +1,52 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Read and write TIFF files"
+HOMEPAGE="
+ https://pypi.org/project/tifffile/
+ https://github.com/cgohlke/tifffile/
+ https://www.lfd.uci.edu/~gohlke/
+"
+SRC_URI="
+ https://github.com/cgohlke/tifffile/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/numpy-1.19.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/dask[${PYTHON_USEDEP}]
+ >=dev-python/fsspec-2021.5.0[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Internet
+ tests/test_tifffile.py::test_class_omexml
+ tests/test_tifffile.py::test_class_omexml_fail
+ tests/test_tifffile.py::test_class_omexml_modulo
+ tests/test_tifffile.py::test_class_omexml_attributes
+ tests/test_tifffile.py::test_class_omexml_multiimage
+ tests/test_tifffile.py::test_write_ome
+ tests/test_tifffile.py::test_write_ome_manual
+ # requires tons of free space
+ tests/test_tifffile.py::test_write_3gb
+ tests/test_tifffile.py::test_write_bigtiff
+ 'tests/test_tifffile.py::test_write_imagej_raw'
+)