summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-07 08:45:50 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-07 09:02:57 +0200
commite7ea97733593e0ba51c91f190931c22e45530cd2 (patch)
tree7611a9800ba81bce98bdf70240427f9e605e872d /dev-python/tabulate
parentdev-python/aws-sam-translator: Bump to 1.52.0 (diff)
downloadgentoo-e7ea97733593e0ba51c91f190931c22e45530cd2.tar.gz
gentoo-e7ea97733593e0ba51c91f190931c22e45530cd2.tar.bz2
gentoo-e7ea97733593e0ba51c91f190931c22e45530cd2.zip
dev-python/tabulate: Bump to 0.9.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tabulate')
-rw-r--r--dev-python/tabulate/Manifest1
-rw-r--r--dev-python/tabulate/tabulate-0.9.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/tabulate/Manifest b/dev-python/tabulate/Manifest
index bc6626b53dbb..b2dd108b1119 100644
--- a/dev-python/tabulate/Manifest
+++ b/dev-python/tabulate/Manifest
@@ -1 +1,2 @@
DIST python-tabulate-0.8.10.gh.tar.gz 49453 BLAKE2B 9bf5c9e937f8ef051792fc57dcd56f1150636bf29493fabe56d4b706df04add41fdffbe1108cb93aa561edc96245ba85e621d4a8b402ace513b55710e6e5498c SHA512 d216076112c0d0f0879c1eeecf2d2c0c30edc84d7289396f1a8d24bca862ef90fcf221a09812b409547696c3b7d4472d431043e359c3a7f67bb8392ce1e95ddc
+DIST python-tabulate-0.9.0.gh.tar.gz 59342 BLAKE2B dc101ab8d1411196619c3d77dd83c84e48f31e148ec3878c2b844a1e26ea1187cc948cfb1eb740d61a667d6b669806a5288c397ea7fcbd59685fedaa9bd0bd2e SHA512 26b0f079f1aca48578883147cb1a2e30e96e0bb85d5af3b72b26eba5f73cea41cf1a0686f666487c8374f95ca0412703168e480c947f1567e6408f941756498b
diff --git a/dev-python/tabulate/tabulate-0.9.0.ebuild b/dev-python/tabulate/tabulate-0.9.0.ebuild
new file mode 100644
index 000000000000..7a751363bab2
--- /dev/null
+++ b/dev-python/tabulate/tabulate-0.9.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+MY_P=python-${P}
+DESCRIPTION="Pretty-print tabular data"
+HOMEPAGE="
+ https://github.com/astanin/python-tabulate/
+ https://pypi.org/project/tabulate/
+"
+SRC_URI="
+ https://github.com/astanin/python-${PN}/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep 'sqlite')
+ dev-python/colorclass[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/numpy[${PYTHON_USEDEP}]
+ ' 'python3*')
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ local EPYTEST_DESELECT=()
+ if ! has_version "dev-python/pandas[${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ test/test_input.py::test_pandas
+ test/test_input.py::test_pandas_firstrow
+ test/test_input.py::test_pandas_keys
+ test/test_output.py::test_pandas_with_index
+ test/test_output.py::test_pandas_without_index
+ test/test_output.py::test_pandas_rst_with_index
+ test/test_output.py::test_pandas_rst_with_named_index
+ )
+ fi
+ epytest
+}