summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-09 07:58:19 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-09 08:01:21 +0100
commit025e2ee11131394d383958b394854777c0f90c47 (patch)
tree726fc1205ed230d3451c30c09a976bc10aa0b2d4 /dev-python/structlog
parentdev-python/pytest-check: Bump to 2.2.4 (diff)
downloadgentoo-025e2ee11131394d383958b394854777c0f90c47.tar.gz
gentoo-025e2ee11131394d383958b394854777c0f90c47.tar.bz2
gentoo-025e2ee11131394d383958b394854777c0f90c47.zip
dev-python/structlog: Bump to 24.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/structlog')
-rw-r--r--dev-python/structlog/Manifest1
-rw-r--r--dev-python/structlog/structlog-24.1.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/structlog/Manifest b/dev-python/structlog/Manifest
index 2e69524ed0f5..b0df7cb07a0d 100644
--- a/dev-python/structlog/Manifest
+++ b/dev-python/structlog/Manifest
@@ -1,2 +1,3 @@
DIST structlog-23.2.0.tar.gz 749288 BLAKE2B c5a619ddacc04e6f2377c66aa343ecfddb8001d5d87c3f10859c2644ce427150771abe4942d57a9ea6db1029af5bde825a0a99218921beea08c4fd147fc5c1cb SHA512 01ddaf3b819da66beefef1810e6d460a2e5ce37f6be3dee144411a3a5db7c81bdfd83a0843172a921406596a2b9f1f87de08caf881c7d701496825203d13bdad
DIST structlog-23.3.0.tar.gz 1340937 BLAKE2B 77abcc01f6a44e9a2486d5a2b8614e35b6c43f19e8077703f3eca41e63476602ba1ae9e960e3e160ff8abc33c0b7db738ff5fed236039a3fc0b7f848a24755d5 SHA512 470e8d1c66185e44cdc0e52b1d60fa13ca5582aec566579a1aac58e11c2537ed4393d08633657d3bea4bceddcc18d394758c653c12c783b6a76c3ffd8b70a0c9
+DIST structlog-24.1.0.tar.gz 1340948 BLAKE2B ad92e145a8a45f7aaf08f26e637b4de42e56d3c5931f022b4524126a5650f30a8e7185ce87bd7e2c91fd48853dfc94585c13184bded1792d2c50153625379c3b SHA512 bb64d8d4ab9afe7482bdaafc3efae833426a256575ff99d013ae1438f3d5d0261842e598028ea644824577f579c5c4704108ce597de0a2eab5ffc1615a609ea6
diff --git a/dev-python/structlog/structlog-24.1.0.ebuild b/dev-python/structlog/structlog-24.1.0.ebuild
new file mode 100644
index 000000000000..bd1dc870f3e9
--- /dev/null
+++ b/dev-python/structlog/structlog-24.1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Structured Logging for Python"
+HOMEPAGE="
+ https://github.com/hynek/structlog/
+ https://pypi.org/project/structlog/
+"
+
+LICENSE="|| ( Apache-2.0 MIT )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ dev-python/hatch-fancy-pypi-readme[${PYTHON_USEDEP}]
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/pretend[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest