summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-06-21 21:41:50 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-06-21 21:41:50 +0300
commit3448ee3b06103f1944971fa205b60845ccc20bc3 (patch)
tree8ff5a684c3a6b1f490239c0d2d9150de9841aa07 /dev-python/stevedore
parentdev-python/openpyxl: drop 3.0.9-r1 (diff)
downloadgentoo-3448ee3b06103f1944971fa205b60845ccc20bc3.tar.gz
gentoo-3448ee3b06103f1944971fa205b60845ccc20bc3.tar.bz2
gentoo-3448ee3b06103f1944971fa205b60845ccc20bc3.zip
dev-python/stevedore: drop 3.4.0, 3.4.0-r1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/stevedore')
-rw-r--r--dev-python/stevedore/Manifest1
-rw-r--r--dev-python/stevedore/stevedore-3.4.0-r1.ebuild53
-rw-r--r--dev-python/stevedore/stevedore-3.4.0.ebuild43
3 files changed, 0 insertions, 97 deletions
diff --git a/dev-python/stevedore/Manifest b/dev-python/stevedore/Manifest
index 977bd26b16d0..ff5d32a5171c 100644
--- a/dev-python/stevedore/Manifest
+++ b/dev-python/stevedore/Manifest
@@ -1,2 +1 @@
-DIST stevedore-3.4.0.tar.gz 513360 BLAKE2B 17030d1aa3cfb566e6f589120eeb6241a1bc0a0dbac0825c48fc96b16316348e7b5e87c6c7fe428faf46cb9e2abbb0da6465f404d5a1fb767fb07c5d8078e481 SHA512 a63897c65fe8deb1b900c4279ce38856863a2581f8e0dec3fc082d0bd6daa5f346bfc6af978b73c3ac24215953c1376a973b800ff8dbbdc1a99f52c99bed7d6d
DIST stevedore-3.5.0.tar.gz 513548 BLAKE2B bb9b1968dbfdbce0764b0c2030e5d555e159e04a88d8fbdb151d3146e7940643c761ff476f7d950c2e83501b9b125e8323a8463d8b4b93b79cc76ddf2f71a362 SHA512 be0f82230d7d4d3cf18dd913e11093ad90744e32a3021d9f88f0be244f56d0e3606af0adef67674c569c41d885837be3f0fc4d58009e036151cc67963a4f2ab3
diff --git a/dev-python/stevedore/stevedore-3.4.0-r1.ebuild b/dev-python/stevedore/stevedore-3.4.0-r1.ebuild
deleted file mode 100644
index 1f6940496911..000000000000
--- a/dev-python/stevedore/stevedore-3.4.0-r1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Manage dynamic plugins for Python applications"
-HOMEPAGE="
- https://opendev.org/openstack/stevedore/
- https://github.com/openstack/stevedore/
- https://pypi.org/project/stevedore/
-"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc64 ~riscv ~s390 ~sparc ~x86"
-
-RDEPEND="
- >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
- test? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/testtools[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests unittest
-distutils_enable_sphinx 'doc/source' \
- '>=dev-python/openstackdocstheme-1.18.1' \
- '>=dev-python/reno-2.5.0' \
- '>=dev-python/sphinx-2.0.0'
-
-python_prepare_all() {
- # Delete spurious data in requirements.txt
- sed -e '/^pbr/d' -i requirements.txt || die
-
- # Known bug in tests
- # https://bugs.launchpad.net/python-stevedore/+bug/1966040
- sed -i -e 's:test_extras:_&:' stevedore/tests/test_extension.py || die
-
- # Also known problem, inside venv
- sed -i -e 's:test_disable_caching_file:_&:' \
- stevedore/tests/test_cache.py || die
-
- distutils-r1_python_prepare_all
-}
diff --git a/dev-python/stevedore/stevedore-3.4.0.ebuild b/dev-python/stevedore/stevedore-3.4.0.ebuild
deleted file mode 100644
index 8cf05b2b83ba..000000000000
--- a/dev-python/stevedore/stevedore-3.4.0.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="Manage dynamic plugins for Python applications"
-HOMEPAGE="https://github.com/openstack/stevedore https://pypi.org/project/stevedore/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~mips ~ppc64 ~s390 sparc x86"
-
-RDEPEND="
- >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
- test? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/testtools[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests unittest
-distutils_enable_sphinx 'doc/source' \
- '>=dev-python/openstackdocstheme-1.18.1' \
- '>=dev-python/reno-2.5.0' \
- '>=dev-python/sphinx-2.0.0'
-
-python_prepare_all() {
- # Delete spurious data in requirements.txt
- sed -e '/^pbr/d' -i requirements.txt || die
-
- # Known bug in tests
- # https://bugs.launchpad.net/python-stevedore/+bug/1966040
- sed -i -e 's:test_extras:_&:' stevedore/tests/test_extension.py || die
-
- distutils-r1_python_prepare_all
-}