summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-11 09:37:39 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-11 09:42:25 +0100
commit4b51686d9c446096b1d8fc3264da552921d56c3a (patch)
tree6e5b2e545ad1622aa2e86a3a12cda70fcdb20931 /dev-python/sqlglot
parentdev-python/qdarkstyle: Bump to 3.2.1 (diff)
downloadgentoo-4b51686d9c446096b1d8fc3264da552921d56c3a.tar.gz
gentoo-4b51686d9c446096b1d8fc3264da552921d56c3a.tar.bz2
gentoo-4b51686d9c446096b1d8fc3264da552921d56c3a.zip
dev-python/sqlglot: Bump to 19.3.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sqlglot')
-rw-r--r--dev-python/sqlglot/Manifest1
-rw-r--r--dev-python/sqlglot/sqlglot-19.3.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/sqlglot/Manifest b/dev-python/sqlglot/Manifest
index 5ee0294dbe65..8cfe0bec16b3 100644
--- a/dev-python/sqlglot/Manifest
+++ b/dev-python/sqlglot/Manifest
@@ -5,3 +5,4 @@ DIST sqlglot-19.1.1.tar.gz 9031814 BLAKE2B 75430d912007d6edf3f045a21f68f35a3dd02
DIST sqlglot-19.1.2.tar.gz 9032813 BLAKE2B 5ed47175decfcdcdf116a5c8676a25f2682ea084d8ddab4c8c147939c159c8c9a2392ebf6466ee32609bb76b86ffe15cd2e7191948067d9ee11e3cdf135331a0 SHA512 e790aedc4c8e5907588e414334121eacfb57f317f06c6c61309a3d932bbb5a1696e2582c5c1cbe5f61a1a85087255dbbb1616dc2f8b19888f80055afc517731c
DIST sqlglot-19.1.3.tar.gz 9039849 BLAKE2B e60834db439b8b6d5d98d1b0cc25a67815b7961b255c2dc6f88072975fec209731f206611143a7287be6d1ef144722367cbbb35f4b7160df5158f5a4a1f2a8c8 SHA512 0d14a9ad56c10972a4141a7f185585d7cb9127f439313ccaca66a0ff225495c3d814747c66d427aaf6ee7c2de7d9959e8544d10071aa5ae05cf1f99018c642e2
DIST sqlglot-19.2.0.tar.gz 9042951 BLAKE2B fd9b70c76f7bcc1ba57bb935d5896de794a981214c23af48b20948d04b7110841ab5fb931aa541101635d723bdb6c395d983a856d598118586d1bc582e341be8 SHA512 4c50f8e7faac643f95c9f9fec6a9ecf797d5f1fa8d8dea10496a320a2a78ab1ba6a3349a47ab1bfca8adc3cb2ad795e56a27d6de7b77256dae65d8ce1a3a9c56
+DIST sqlglot-19.3.1.tar.gz 9054462 BLAKE2B ae44c5398cf976e5a624b01e2b9078275da43dfa6e0c4a112a1c5dcc6a2e5a6c5c84d0005911651b920c4e2ff09a668c10d55a56c843c2ba423fc456897647b5 SHA512 46375ff738bf2cd454e24dd789afff4318cb186c87c232613c5ec70694db526ec28dae853b59014eeef34a2b746e19cb418965c1bd55066bb1eee278f12895ea
diff --git a/dev-python/sqlglot/sqlglot-19.3.1.ebuild b/dev-python/sqlglot/sqlglot-19.3.1.ebuild
new file mode 100644
index 000000000000..368b77416b42
--- /dev/null
+++ b/dev-python/sqlglot/sqlglot-19.3.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi optfeature
+
+DESCRIPTION="An easily customizable SQL parser and transpiler"
+HOMEPAGE="
+ https://sqlglot.com/
+ https://github.com/tobymao/sqlglot/
+ https://pypi.org/project/sqlglot/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+EPYTEST_IGNORE=(
+ # Tests require pyspark or duckdb which aren't in the tree.
+ # Pandas would be a requirement normally, but it gets ignored by proxy.
+ "tests/dataframe/integration/test_dataframe.py"
+ "tests/dataframe/integration/test_grouped_data.py"
+ "tests/dataframe/integration/test_session.py"
+ "tests/test_executor.py"
+ "tests/test_optimizer.py"
+)
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "simplifying timedelta expressions" dev-python/python-dateutil
+}