summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-03-13 11:44:08 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-03-13 11:44:40 -0500
commit92c1d412f49cfc25180f14321c463d65be77f63f (patch)
treec1239564fff2833f71c5e529e9ff374bb158b583 /dev-python/sqlalchemy-migrate/sqlalchemy-migrate-0.12.0.ebuild
parentdev-python/sqlalchemy: 1.2.18 bump (diff)
downloadgentoo-92c1d412f49cfc25180f14321c463d65be77f63f.tar.gz
gentoo-92c1d412f49cfc25180f14321c463d65be77f63f.tar.bz2
gentoo-92c1d412f49cfc25180f14321c463d65be77f63f.zip
dev-python/sqlalchemy-migrate: 0.12.0 bump
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/sqlalchemy-migrate/sqlalchemy-migrate-0.12.0.ebuild')
-rw-r--r--dev-python/sqlalchemy-migrate/sqlalchemy-migrate-0.12.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/sqlalchemy-migrate/sqlalchemy-migrate-0.12.0.ebuild b/dev-python/sqlalchemy-migrate/sqlalchemy-migrate-0.12.0.ebuild
new file mode 100644
index 000000000000..a13a76d3c991
--- /dev/null
+++ b/dev-python/sqlalchemy-migrate/sqlalchemy-migrate-0.12.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="SQLAlchemy Schema Migration Tools"
+HOMEPAGE="https://pypi.org/project/sqlalchemy-migrate/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="doc"
+
+CDEPEND=">=dev-python/pbr-1.8.0[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+RDEPEND=">=dev-python/sqlalchemy-0.9.6[${PYTHON_USEDEP}]
+ dev-python/decorator[${PYTHON_USEDEP}]
+ >=dev-python/six-1.7.0[${PYTHON_USEDEP}]
+ dev-python/python-sqlparse[${PYTHON_USEDEP}]
+ >=dev-python/tempita-0.4[${PYTHON_USEDEP}]"
+# Testsuite requires a missing dep and errors with poor report output
+
+PATCHES=( "${FILESDIR}/${PN}-0.11-disable-sphinx-exts.patch" )
+
+python_compile_all() {
+ if use doc; then
+ einfo ""; einfo "The build seeks to import modules from an installed state of the package"
+ einfo "simply ignore all warnings / errors of failure to import module migrate.<module>"; einfo ""
+ emake -C doc/source html || die "Generation of documentation failed"
+ fi
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/source/_build/html/. )
+ distutils-r1_python_install_all
+}