summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-04-08 09:56:16 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-04-08 09:56:16 +0200
commited030e1abdf892e69bc9fb5e0834ea3647c45906 (patch)
treee8d4a2fce0afa02dd7b735fcea46cea8afd943a6 /dev-python/spyder-notebook
parentprofiles/package.mask: drop mask of net-misc/mikutter (diff)
downloadgentoo-ed030e1abdf892e69bc9fb5e0834ea3647c45906.tar.gz
gentoo-ed030e1abdf892e69bc9fb5e0834ea3647c45906.tar.bz2
gentoo-ed030e1abdf892e69bc9fb5e0834ea3647c45906.zip
dev-python/spyder-notebook: add 0.4.1
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/spyder-notebook')
-rw-r--r--dev-python/spyder-notebook/Manifest1
-rw-r--r--dev-python/spyder-notebook/spyder-notebook-0.4.1.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/spyder-notebook/Manifest b/dev-python/spyder-notebook/Manifest
index 1a8a3fe5afd3..7b562f346886 100644
--- a/dev-python/spyder-notebook/Manifest
+++ b/dev-python/spyder-notebook/Manifest
@@ -1 +1,2 @@
DIST spyder-notebook-0.4.0.gh.tar.gz 3869758 BLAKE2B db809e9a2b93206ba0236e825b7d8f612efe552be5b9bbcdd60021ee143f16674e05847834bbd63a801c32e2264e5335685887aad0519033a315b3c2c0fcd3d6 SHA512 ab97429d276af815411b9a63bc04e291e5ed596bb9c551be8161e71761fc21a61b896b73ec1d93c9a2b4561ba228b93ac86f3b542a515cbfc651e9e218f6f778
+DIST spyder-notebook-0.4.1.tar.gz 1756246 BLAKE2B daccd224f822d10b0bc527f6e12a46b975631c1eee4edd1e431ff8a71e126d4ff2006853b05146bdef3c8978a34a38d1c30ff9da9076f9c954a7ecdbe9eab4af SHA512 f4ad23ba218dec708f876fe13b11e172df2430c9c9e57916a8f10f43f3728788801d7749b37a7474b329fa8750c0d08ddbd5131142035868f23c1975228d840e
diff --git a/dev-python/spyder-notebook/spyder-notebook-0.4.1.ebuild b/dev-python/spyder-notebook/spyder-notebook-0.4.1.ebuild
new file mode 100644
index 000000000000..2db34e4a9110
--- /dev/null
+++ b/dev-python/spyder-notebook/spyder-notebook-0.4.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+
+inherit distutils-r1 pypi virtualx
+
+DESCRIPTION="Jupyter notebook integration with Spyder"
+HOMEPAGE="https://github.com/spyder-ide/spyder-notebook"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/jupyter-core[${PYTHON_USEDEP}]
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ >=dev-python/notebook-4.3[${PYTHON_USEDEP}]
+ dev-python/qdarkstyle[${PYTHON_USEDEP}]
+ dev-python/QtPy[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ >=dev-python/spyder-5.4.3[${PYTHON_USEDEP}]
+ <dev-python/spyder-6[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-qt[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( "README.md" "RELEASE.md" "CHANGELOG.md" "doc/example.gif" )
+
+distutils_enable_tests pytest
+
+python_test() {
+ virtx epytest
+}