summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-09-24 12:58:05 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-09-24 13:11:52 +0200
commit7373a8a81eb4f97e1d06e29c7e7c7b2cde0d3795 (patch)
treee2970ce6f53d0df78b42318b47aea62cd51b012f /dev-python/spyder-notebook
parentdev-python/shiboken2: remove unused patches (diff)
downloadgentoo-7373a8a81eb4f97e1d06e29c7e7c7b2cde0d3795.tar.gz
gentoo-7373a8a81eb4f97e1d06e29c7e7c7b2cde0d3795.tar.bz2
gentoo-7373a8a81eb4f97e1d06e29c7e7c7b2cde0d3795.zip
dev-python/spyder-notebook: add 0.4.0, re-add package
This reverts commit 74b08e2d8765e3eed20bfa11440af6602e9eea42. Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/spyder-notebook')
-rw-r--r--dev-python/spyder-notebook/Manifest1
-rw-r--r--dev-python/spyder-notebook/metadata.xml12
-rw-r--r--dev-python/spyder-notebook/spyder-notebook-0.4.0.ebuild45
3 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/spyder-notebook/Manifest b/dev-python/spyder-notebook/Manifest
new file mode 100644
index 000000000000..1a8a3fe5afd3
--- /dev/null
+++ b/dev-python/spyder-notebook/Manifest
@@ -0,0 +1 @@
+DIST spyder-notebook-0.4.0.gh.tar.gz 3869758 BLAKE2B db809e9a2b93206ba0236e825b7d8f612efe552be5b9bbcdd60021ee143f16674e05847834bbd63a801c32e2264e5335685887aad0519033a315b3c2c0fcd3d6 SHA512 ab97429d276af815411b9a63bc04e291e5ed596bb9c551be8161e71761fc21a61b896b73ec1d93c9a2b4561ba228b93ac86f3b542a515cbfc651e9e218f6f778
diff --git a/dev-python/spyder-notebook/metadata.xml b/dev-python/spyder-notebook/metadata.xml
new file mode 100644
index 000000000000..32373b5ff3a3
--- /dev/null
+++ b/dev-python/spyder-notebook/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>andrewammerlaan@gentoo.org</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">spyder-notebook</remote-id>
+ </upstream>
+ <stabilize-allarches/>
+</pkgmetadata>
diff --git a/dev-python/spyder-notebook/spyder-notebook-0.4.0.ebuild b/dev-python/spyder-notebook/spyder-notebook-0.4.0.ebuild
new file mode 100644
index 000000000000..4d32ebced7fc
--- /dev/null
+++ b/dev-python/spyder-notebook/spyder-notebook-0.4.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+# ERROR: Server components are missing!! Please run 'python setup.py sdist' first.
+# DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Jupyter notebook integration with Spyder"
+HOMEPAGE="https://github.com/spyder-ide/spyder-notebook"
+SRC_URI="https://github.com/spyder-ide/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/jupyter_core[${PYTHON_USEDEP}]
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ >=dev-python/notebook-4.3[${PYTHON_USEDEP}]
+ dev-python/qdarkstyle[${PYTHON_USEDEP}]
+ dev-python/QtPy[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ >=dev-python/spyder-5.3.3[${PYTHON_USEDEP}]
+ <dev-python/spyder-6[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]
+"
+
+BDEPEND="test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-qt[${PYTHON_USEDEP}]
+)"
+
+DOCS=( "README.md" "RELEASE.md" "CHANGELOG.md" "doc/example.gif" )
+
+distutils_enable_tests pytest
+
+python_test() {
+ virtx epytest
+}