summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-13 08:05:03 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-13 09:19:56 +0100
commit39684f0a11b82e3b2272b7c60337057d44791945 (patch)
tree5427e8995e7b620963e37bcce561a79705641a03 /dev-python/sphinxcontrib-devhelp
parentdev-python/sphinxcontrib-htmlhelp: Bump to 2.0.5 (diff)
downloadgentoo-39684f0a11b82e3b2272b7c60337057d44791945.tar.gz
gentoo-39684f0a11b82e3b2272b7c60337057d44791945.tar.bz2
gentoo-39684f0a11b82e3b2272b7c60337057d44791945.zip
dev-python/sphinxcontrib-devhelp: Bump to 1.0.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinxcontrib-devhelp')
-rw-r--r--dev-python/sphinxcontrib-devhelp/Manifest1
-rw-r--r--dev-python/sphinxcontrib-devhelp/sphinxcontrib-devhelp-1.0.6.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-devhelp/Manifest b/dev-python/sphinxcontrib-devhelp/Manifest
index a08f2872e528..1b3c004fb5b8 100644
--- a/dev-python/sphinxcontrib-devhelp/Manifest
+++ b/dev-python/sphinxcontrib-devhelp/Manifest
@@ -1 +1,2 @@
DIST sphinxcontrib_devhelp-1.0.5.tar.gz 12343 BLAKE2B f9c46d07888eab1bddcecce3a862fe503a0187620768a40f360fa985dee9cfaaf8d28f03c6a08e0b174788639675ee715141287bd7bf04ff403459e9858e4f9c SHA512 4412f9711b981c8e3beaa9940c09d02c21dc5e303a0ab80ca401f4cc5444bd159070a065a20c0e6f721202c05d880f20244ca5ff32df5911c8a4ba3d00ed9121
+DIST sphinxcontrib_devhelp-1.0.6.tar.gz 12480 BLAKE2B 40fcbd13156cba5d904ee30e98284f0bc6f53e4dc2003cbeca6cb0189122d8b453ca7ab849570bbea615a2b0d4fc016b1ff6f72b2f8ec337b9424b4fc9ff8a57 SHA512 97ab48f4adc16140323220bd23447d74fdec1d223e64c06a325df9568436bbce31edf5b33103dc81e0eb937f7ac8328b012fce80d2d6fd995dc0f63e9fb15f77
diff --git a/dev-python/sphinxcontrib-devhelp/sphinxcontrib-devhelp-1.0.6.ebuild b/dev-python/sphinxcontrib-devhelp/sphinxcontrib-devhelp-1.0.6.ebuild
new file mode 100644
index 000000000000..1b24268040b4
--- /dev/null
+++ b/dev-python/sphinxcontrib-devhelp/sphinxcontrib-devhelp-1.0.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Sphinx extension which outputs Devhelp documents"
+HOMEPAGE="
+ https://www.sphinx-doc.org/
+ https://github.com/sphinx-doc/sphinxcontrib-devhelp/
+ https://pypi.org/project/sphinxcontrib-devhelp/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+PDEPEND="
+ >=dev-python/sphinx-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? ( ${PDEPEND} )
+"
+
+distutils_enable_tests pytest