summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-01-19 08:49:55 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-01-19 08:50:13 +0200
commit832c501faf2239f5371de133a29a7eaca68a3121 (patch)
treec8f9cfb41ea885ef681308d6ff09271dc049aad4 /dev-python/socksio
parentapp-doc/devmanual: Depend on >=dev-libs/libxml2-2.9.12 (diff)
downloadgentoo-832c501faf2239f5371de133a29a7eaca68a3121.tar.gz
gentoo-832c501faf2239f5371de133a29a7eaca68a3121.tar.bz2
gentoo-832c501faf2239f5371de133a29a7eaca68a3121.zip
dev-python/socksio: initial import
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/socksio')
-rw-r--r--dev-python/socksio/Manifest1
-rw-r--r--dev-python/socksio/metadata.xml13
-rw-r--r--dev-python/socksio/socksio-1.0.0.ebuild25
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/socksio/Manifest b/dev-python/socksio/Manifest
new file mode 100644
index 000000000000..13d23662b672
--- /dev/null
+++ b/dev-python/socksio/Manifest
@@ -0,0 +1 @@
+DIST socksio-1.0.0.tar.gz 19055 BLAKE2B aa6bff92ae19611151070fc8e9661d532bd970d5d9d7ab8752fe77f7b4444957710ceff09d76b9f69ff71b48daf54659b4d523bc6dd01a28580d25f1e0ac055f SHA512 89bce7294555e2623df68e99352c27b83af38a4fcc4e3b86c8826c9c4bf545eeaf0a6328b000cfe1d286fa442c756c4579b4887cff03bc9e559cd66414a7ac6f
diff --git a/dev-python/socksio/metadata.xml b/dev-python/socksio/metadata.xml
new file mode 100644
index 000000000000..0e61b117868b
--- /dev/null
+++ b/dev-python/socksio/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">socksio</remote-id>
+ <remote-id type="github">sethmlarson/socksio</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/socksio/socksio-1.0.0.ebuild b/dev-python/socksio/socksio-1.0.0.ebuild
new file mode 100644
index 000000000000..b22dc901f6ec
--- /dev/null
+++ b/dev-python/socksio/socksio-1.0.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=flit
+inherit distutils-r1
+
+DESCRIPTION="Sans-I/O implementation of SOCKS4, SOCKS4A, and SOCKS5"
+HOMEPAGE="https://pypi.org/project/socksio/ https://github.com/sethmlarson/socksio"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # remove coverage args for tests
+ rm pytest.ini || die
+
+ distutils-r1_src_prepare
+}