summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-06 10:04:41 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-06 10:21:50 +0200
commit2d2580cb10a91f4238118a58cf56a70d2fbfc9a4 (patch)
treefdc8d361746a8b0649e1f91c56411aea8f4bf855 /dev-python/six
parentdev-python/eventlet: Bump to 0.31.0 (diff)
downloadgentoo-2d2580cb10a91f4238118a58cf56a70d2fbfc9a4.tar.gz
gentoo-2d2580cb10a91f4238118a58cf56a70d2fbfc9a4.tar.bz2
gentoo-2d2580cb10a91f4238118a58cf56a70d2fbfc9a4.zip
dev-python/six: Bump to 1.16.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/six')
-rw-r--r--dev-python/six/Manifest1
-rw-r--r--dev-python/six/six-1.16.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/six/Manifest b/dev-python/six/Manifest
index 0317468df3ef..2c93586d43ea 100644
--- a/dev-python/six/Manifest
+++ b/dev-python/six/Manifest
@@ -1 +1,2 @@
DIST six-1.15.0.tar.gz 33917 BLAKE2B 57e852b6c35dd19e256814c0371cfbc26141b0f25a31f79a1cbd1b0cdd7d3cacf1236b96f5452f968cc426e6dff4d1ad70a9f2432bc361ba3c8c17fd40fe7582 SHA512 eb840ac17f433f1fc4af56de75cfbfe0b54e6a737bb23c453bf09a4a13d768d153e46064880dc763f4c5cc2785b78ea6d3d3b4a41fed181cb9064837e3f699a9
+DIST six-1.16.0.tar.gz 34041 BLAKE2B 764f8da9a0d89e95af002c79c2b19e852fdec9a6819655c57be019b48bd65a5f7909473e71887e6080073f381f983c077487591d4e44297542cf6b9a29ba42b8 SHA512 076fe31c8f03b0b52ff44346759c7dc8317da0972403b84dfe5898179f55acdba6c78827e0f8a53ff20afe8b76432c6fe0d655a75c24259d9acbaa4d9e8015c0
diff --git a/dev-python/six/six-1.16.0.ebuild b/dev-python/six/six-1.16.0.ebuild
new file mode 100644
index 000000000000..7c6266910ab4
--- /dev/null
+++ b/dev-python/six/six-1.16.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python 2 and 3 compatibility library"
+HOMEPAGE="https://github.com/benjaminp/six https://pypi.org/project/six/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+distutils_enable_sphinx documentation --no-autodoc
+distutils_enable_tests pytest
+
+python_test() {
+ local deselect=()
+ [[ ${EPYTHON} == pypy3 ]] && deselect+=(
+ 'test_six.py::test_move_items[dbm_ndbm]'
+ )
+
+ epytest ${deselect[@]/#/--deselect }
+}