summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-02-09 07:06:24 -0500
committerIonen Wolkens <ionen@gentoo.org>2024-02-09 07:18:30 -0500
commit5dc4027e4d71c5737b91e1fec80bea334812b6a8 (patch)
tree68d002bd9519b39358de3bf7d46568ae21f0491b /dev-python/sip
parentdev-python/sip: drop 6.8.1 (diff)
downloadgentoo-5dc4027e4d71c5737b91e1fec80bea334812b6a8.tar.gz
gentoo-5dc4027e4d71c5737b91e1fec80bea334812b6a8.tar.bz2
gentoo-5dc4027e4d71c5737b91e1fec80bea334812b6a8.zip
dev-python/sip: add 6.8.3
Largely identical to 6.8.2 but marks more bits deprecated in preparation for sip-7. Note that sip-7 is not that far off (expected around September 2024), and any packages still using deprecated bits will be broken. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-python/sip')
-rw-r--r--dev-python/sip/Manifest1
-rw-r--r--dev-python/sip/sip-6.8.3.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/sip/Manifest b/dev-python/sip/Manifest
index 670f13369849..3cf0129e2292 100644
--- a/dev-python/sip/Manifest
+++ b/dev-python/sip/Manifest
@@ -1 +1,2 @@
DIST sip-6.8.2.tar.gz 987521 BLAKE2B 318058b2c7f03cb5cdbd56628233eedf26edd10a61e7ef505d463d01542cceb19e2eb15ca82eb6679c4ae646ecbbbca636ef105a2e73c368fdc69a621a28a4c2 SHA512 7edc3d10256d6622179cb4d207227935786399de52adcffc7fa9dd9d05b32488823642ed128e30195c3e71e470c48ae49e2c2225b76116e849496d2197571d4f
+DIST sip-6.8.3.tar.gz 987656 BLAKE2B 57cc4010aae64eec7e0f338d9653463c7381b639aa8efca978a3f3296550a37b3a09b52933a2c2cd354a65155841952d7ca045b0b774945a382c29a8d597951e SHA512 8a0ff1c16ead4c2b1c53963a015fb3d149362f649eeec2523e6b243945493f28f5ecf29aabbf5cee5f7909ded40d64a1f469d2d0c1b3c33244e6213ab23ec733
diff --git a/dev-python/sip/sip-6.8.3.ebuild b/dev-python/sip/sip-6.8.3.ebuild
new file mode 100644
index 000000000000..a1fec821017b
--- /dev/null
+++ b/dev-python/sip/sip-6.8.3.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python bindings generator for C/C++ libraries"
+HOMEPAGE="https://www.riverbankcomputing.com/software/sip/"
+
+LICENSE="|| ( GPL-2 GPL-3 SIP )"
+SLOT="5"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/tomli[${PYTHON_USEDEP}]' 3.10)
+"
+
+distutils_enable_sphinx doc --no-autodoc