summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-08-01 11:58:58 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-08-02 01:19:39 +0200
commit3f389ecfd471a3003664c5e83003d147958a6ec1 (patch)
tree3fa84eb5f444c08d6a7988de72f57d0f26f19758 /dev-python/sip
parentdev-python/PyQt5-sip: Drop python2_7 (diff)
downloadgentoo-3f389ecfd471a3003664c5e83003d147958a6ec1.tar.gz
gentoo-3f389ecfd471a3003664c5e83003d147958a6ec1.tar.bz2
gentoo-3f389ecfd471a3003664c5e83003d147958a6ec1.zip
dev-python/sip: Drop python2_7
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-python/sip')
-rw-r--r--dev-python/sip/sip-4.19.22-r1.ebuild (renamed from dev-python/sip/sip-4.19.22.ebuild)6
-rw-r--r--dev-python/sip/sip-4.19.23-r1.ebuild (renamed from dev-python/sip/sip-4.19.23.ebuild)6
2 files changed, 2 insertions, 10 deletions
diff --git a/dev-python/sip/sip-4.19.22.ebuild b/dev-python/sip/sip-4.19.22-r1.ebuild
index 6dfdf1956711..0990210585d5 100644
--- a/dev-python/sip/sip-4.19.22.ebuild
+++ b/dev-python/sip/sip-4.19.22-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7,8,9} )
+PYTHON_COMPAT=( python3_{6,7,8,9} )
inherit python-r1 toolchain-funcs
DESCRIPTION="Python extension module generator for C and C++ libraries"
@@ -50,10 +50,6 @@ src_prepare() {
src_configure() {
configuration() {
- if ! python_is_python3; then
- local CFLAGS="${CFLAGS} -fno-strict-aliasing"
- fi
-
local incdir=$(python_get_includedir)
local myconf=(
"${PYTHON}"
diff --git a/dev-python/sip/sip-4.19.23.ebuild b/dev-python/sip/sip-4.19.23-r1.ebuild
index 1bb8cb20eabd..81dde8c08811 100644
--- a/dev-python/sip/sip-4.19.23.ebuild
+++ b/dev-python/sip/sip-4.19.23-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{6,7,8,9} )
+PYTHON_COMPAT=( python3_{6,7,8,9} )
inherit python-r1 toolchain-funcs
DESCRIPTION="Python extension module generator for C and C++ libraries"
@@ -50,10 +50,6 @@ src_prepare() {
src_configure() {
configuration() {
- if ! python_is_python3; then
- local CFLAGS="${CFLAGS} -fno-strict-aliasing"
- fi
-
local incdir=$(python_get_includedir)
local myconf=(
"${PYTHON}"