summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/simplekv
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/simplekv')
-rw-r--r--dev-python/simplekv/Manifest2
-rw-r--r--dev-python/simplekv/metadata.xml14
-rw-r--r--dev-python/simplekv/simplekv-0.9.2.ebuild20
-rw-r--r--dev-python/simplekv/simplekv-0.9.3.ebuild20
4 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/simplekv/Manifest b/dev-python/simplekv/Manifest
new file mode 100644
index 000000000000..2503d42448bf
--- /dev/null
+++ b/dev-python/simplekv/Manifest
@@ -0,0 +1,2 @@
+DIST simplekv-0.9.2.tar.gz 13750 SHA256 448608199a9f76a25529005b5a28a4e548afd623e2b7109563b9ebe6ef4f3aac SHA512 cfa17cc0920d4a0513c56443c30ed07a77130f689d71130a058e2a46a5b9dbfc22b1fd21d6fee973fc00242c6b9391143a4db91f9c1937ea7f64daa898a8f045 WHIRLPOOL 40f62efaba344aed99b3e6bae80eb22021a93958654a2fe2d881ece808a93f830923fbd2f00d96adb46442d6bcf3c66a71fc805a49f46e331db10df24c1b2621
+DIST simplekv-0.9.3.tar.gz 14585 SHA256 f82e11b42222c13201ff7bc97b4684953287150e8c51c28b0028be489bb214d1 SHA512 1d83c485b4e3d28ce2e0080b6ef424393ea26ae9fcce75a0852b07d66bcf134815e292b590f1a1ff4083b5202633d2cf837a5ebd7b577353ae94a0be5491436b WHIRLPOOL 3793ba874530087854a57613504c6344bcb69c41bb49268f7e92edd02c54979ee5b08308bc9651c4983b756d7057398d837cf8366cef8d37114528630c971340
diff --git a/dev-python/simplekv/metadata.xml b/dev-python/simplekv/metadata.xml
new file mode 100644
index 000000000000..4b9133c78f3b
--- /dev/null
+++ b/dev-python/simplekv/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>aballier@gentoo.org</email>
+ <name>Alexis Ballier</name>
+ <description>Python team can take the package if they wish.</description>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">simplekv</remote-id>
+ <remote-id type="github">mbr/simplekv</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/simplekv/simplekv-0.9.2.ebuild b/dev-python/simplekv/simplekv-0.9.2.ebuild
new file mode 100644
index 000000000000..5eeab9456446
--- /dev/null
+++ b/dev-python/simplekv/simplekv-0.9.2.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A key-value storage for binary data, support many backends."
+HOMEPAGE="https://pypi.python.org/pypi/simplekv/ https://github.com/mbr/simplekv"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
diff --git a/dev-python/simplekv/simplekv-0.9.3.ebuild b/dev-python/simplekv/simplekv-0.9.3.ebuild
new file mode 100644
index 000000000000..de2f9537a8ca
--- /dev/null
+++ b/dev-python/simplekv/simplekv-0.9.3.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A key-value storage for binary data, support many backends."
+HOMEPAGE="https://pypi.python.org/pypi/simplekv/ https://github.com/mbr/simplekv"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""