summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Wingate <parona@protonmail.com>2023-08-07 07:45:56 +0300
committerSam James <sam@gentoo.org>2023-09-01 13:16:16 +0100
commitc034c18853f510d292a132754623a9988ab7ef14 (patch)
tree3866c240805eeea964e3b91ebf1187d8d0bd2c60 /dev-python/simplejson
parentdev-python/msgpack: use variable to disable native-extensions (diff)
downloadgentoo-c034c18853f510d292a132754623a9988ab7ef14.tar.gz
gentoo-c034c18853f510d292a132754623a9988ab7ef14.tar.bz2
gentoo-c034c18853f510d292a132754623a9988ab7ef14.zip
dev-python/simplejson: comment for native-extensions on pypy3
Signed-off-by: Alfred Wingate <parona@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/simplejson')
-rw-r--r--dev-python/simplejson/simplejson-3.19.1.ebuild2
1 files changed, 2 insertions, 0 deletions
diff --git a/dev-python/simplejson/simplejson-3.19.1.ebuild b/dev-python/simplejson/simplejson-3.19.1.ebuild
index 3d2130d9f7c4..a014c1d7ed9b 100644
--- a/dev-python/simplejson/simplejson-3.19.1.ebuild
+++ b/dev-python/simplejson/simplejson-3.19.1.ebuild
@@ -25,6 +25,8 @@ DOCS=( README.rst CHANGES.txt )
distutils_enable_tests unittest
src_configure() {
+ # native-extensions are always disabled on PyPy
+ # https://github.com/simplejson/simplejson/blob/master/setup.py#L121
export DISABLE_SPEEDUPS=$(usex native-extensions 0 1)
use native-extensions && export REQUIRE_SPEEDUPS=1
}