summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2017-03-11 21:21:35 +0100
committerCédric Krier <cedk@gentoo.org>2017-03-11 21:21:35 +0100
commit367729d26e73b8d933d66318a0d04540eead3a26 (patch)
treef067c1a0dcc25e4d718b9ece897c8c897c694509 /dev-python/simpleeval/simpleeval-0.9.5.ebuild
parentdev-python/zeep: Version bumps to 1.1.0 for bug #611920 (diff)
downloadgentoo-367729d26e73b8d933d66318a0d04540eead3a26.tar.gz
gentoo-367729d26e73b8d933d66318a0d04540eead3a26.tar.bz2
gentoo-367729d26e73b8d933d66318a0d04540eead3a26.zip
dev-python/simpleeval: Version bumps to 0.9.5
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/simpleeval/simpleeval-0.9.5.ebuild')
-rw-r--r--dev-python/simpleeval/simpleeval-0.9.5.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/simpleeval/simpleeval-0.9.5.ebuild b/dev-python/simpleeval/simpleeval-0.9.5.ebuild
new file mode 100644
index 000000000000..dacb7bcd0b14
--- /dev/null
+++ b/dev-python/simpleeval/simpleeval-0.9.5.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A simple, safe single expression evaluator library"
+HOMEPAGE="https://github.com/danthedeckie/simpleeval"
+SRC_URI="mirror://pypi/s/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DOCS="README.rst"
+
+python_test() {
+ esetup.py test
+}