summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-23 09:21:00 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-23 09:29:00 +0100
commitb77a8cd82f7b20075a7bbcca7a59bd63b55a4d2e (patch)
tree4d958f9168e4125a852b973888d8684c23431e27 /dev-python/sentry-sdk
parentdev-python/editorconfig-core-py: Add python@ as co-maint (diff)
downloadgentoo-b77a8cd82f7b20075a7bbcca7a59bd63b55a4d2e.tar.gz
gentoo-b77a8cd82f7b20075a7bbcca7a59bd63b55a4d2e.tar.bz2
gentoo-b77a8cd82f7b20075a7bbcca7a59bd63b55a4d2e.zip
dev-python/sentry-sdk: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sentry-sdk')
-rw-r--r--dev-python/sentry-sdk/Manifest1
-rw-r--r--dev-python/sentry-sdk/sentry-sdk-0.19.1.ebuild85
2 files changed, 0 insertions, 86 deletions
diff --git a/dev-python/sentry-sdk/Manifest b/dev-python/sentry-sdk/Manifest
index e64e77905b5d..0e5589a6768d 100644
--- a/dev-python/sentry-sdk/Manifest
+++ b/dev-python/sentry-sdk/Manifest
@@ -1,3 +1,2 @@
-DIST sentry-sdk-0.19.1.tar.gz 186747 BLAKE2B ae26751ac2e640b86b3c7426829e699cfdbd1c35e70edf0f1f835e35da82f658990a5f61adc4e7b93b032f6c9824d0df90bb2146f125c1fb846c3436228d5516 SHA512 dd4234a36920893e55026ba5ab8b1476cbc91b035a4b4c78f9dcf29cc8e232dc49c6f7312b8fb3d64cf469552d08ef5cadb65d3a7fb58ba73b87e43375c27c8d
DIST sentry-sdk-0.19.4.tar.gz 205992 BLAKE2B fdf7d1a29a04be01bc3b7dd7ef7ee0ad33bb03241d9c62e152aa829b2faddb52e7307705ec4f7d89db912ac625de477999167ea66372bcf9304caef31fb65aa4 SHA512 bc8d23b6767a1809ecb4d43becbe266f1e068cfb953cbad280313e54fd3d679308eace42fd880f356bac2f216894e45ee1b51eb2fc74f73f9e433bae406a2a37
DIST sentry-sdk-0.19.5.tar.gz 206164 BLAKE2B 9d7ce2a64fcb511c659188dc18bc4af18052c0f12ff5d31848f341ef20cbc6c9cf1102d17e6e8d8b741eb8000f94978f840f3ec66b43367820e0ccce97b1fd1b SHA512 082ace137656e8cc8317e70cf4fe9823ccf8cc3ed7b54af059990cede72179924a36896a31a806de4adbbf3bd66e54d5385eb630c047b929583e32c39ed69d61
diff --git a/dev-python/sentry-sdk/sentry-sdk-0.19.1.ebuild b/dev-python/sentry-sdk/sentry-sdk-0.19.1.ebuild
deleted file mode 100644
index 4851cb547191..000000000000
--- a/dev-python/sentry-sdk/sentry-sdk-0.19.1.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6..9} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python client for Sentry"
-HOMEPAGE="https://getsentry.com https://pypi.org/project/sentry-sdk/"
-SRC_URI="https://github.com/getsentry/sentry-python/archive/${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/sentry-python-${PV}"
-
-LICENSE="PSF-2"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~ppc ~ppc64 x86"
-
-RDEPEND="
- dev-python/urllib3[${PYTHON_USEDEP}]
- dev-python/certifi[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/asttokens[${PYTHON_USEDEP}]
- <dev-python/dnspython-2[${PYTHON_USEDEP}]
- dev-python/executing[${PYTHON_USEDEP}]
- dev-python/eventlet[${PYTHON_USEDEP}]
- dev-python/fakeredis[${PYTHON_USEDEP}]
- dev-python/flask-login[${PYTHON_USEDEP}]
- dev-python/gevent[${PYTHON_USEDEP}]
- dev-python/jsonschema[${PYTHON_USEDEP}]
- dev-python/pyrsistent[${PYTHON_USEDEP}]
- dev-python/pytest-aiohttp[${PYTHON_USEDEP}]
- dev-python/pytest-forked[${PYTHON_USEDEP}]
- dev-python/pytest-localserver[${PYTHON_USEDEP}]
- dev-python/werkzeug[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/aiocontextvars[${PYTHON_USEDEP}]
- dev-python/contextvars[${PYTHON_USEDEP}]
- ' python3_6)
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local deselect=(
- # tests require Internet access
- --deselect tests/integrations/stdlib/test_httplib.py
- --deselect tests/integrations/requests/test_requests.py
- # wtf is it supposed to do?!
- --deselect tests/integrations/gcp/test_gcp.py
- # fails on py3.6, hangs on py3.7+
- --deselect
- 'tests/test_transport.py::test_transport_works[eventlet'
- # TODO
- --deselect
- 'tests/test_basics.py::test_auto_enabling_integrations_catches_import_error'
- --deselect
- tests/test_client.py::test_databag_depth_stripping
- --deselect
- tests/test_client.py::test_databag_string_stripping
- --deselect
- tests/test_client.py::test_databag_breadth_stripping
- # test_filename: apparently unhappy about pytest being called pytest
- --deselect 'tests/utils/test_general.py::test_filename'
- # test_circular_references: apparently fragile
- --deselect
- 'tests/integrations/threading/test_threading.py::test_circular_references'
- )
- [[ ${EPYTHON} == python3.6 ]] && deselect+=(
- # broken with contextvars on py3.6
- --deselect
- 'tests/utils/test_contextvars.py::test_leaks[greenlet]'
- --deselect
- 'tests/test_transport.py::test_transport_works[greenlet'
- )
-
- # Prevent tests/integrations/modules/test_modules.py:test_basic failure
- # Needs to detect sentry-sdk in the installed modules
- distutils_install_for_testing
-
- pytest -vv "${deselect[@]}" || die "Tests failed with ${EPYTHON}"
-}