summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-01 06:25:12 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-01 06:38:14 +0100
commitc85458e80757ab60e4521a748e6b19b749218137 (patch)
treecb5c07c6c1a2bf57160bb4077991594e4db0b1df /dev-python/scikit-build-core
parentdev-python/patsy: Bump to 0.5.4 (diff)
downloadgentoo-c85458e80757ab60e4521a748e6b19b749218137.tar.gz
gentoo-c85458e80757ab60e4521a748e6b19b749218137.tar.bz2
gentoo-c85458e80757ab60e4521a748e6b19b749218137.zip
dev-python/scikit-build-core: Bump to 0.7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/scikit-build-core')
-rw-r--r--dev-python/scikit-build-core/Manifest1
-rw-r--r--dev-python/scikit-build-core/scikit-build-core-0.7.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/scikit-build-core/Manifest b/dev-python/scikit-build-core/Manifest
index 3fad92e541ce..9028be4c1dc5 100644
--- a/dev-python/scikit-build-core/Manifest
+++ b/dev-python/scikit-build-core/Manifest
@@ -1 +1,2 @@
DIST scikit_build_core-0.6.1.tar.gz 191098 BLAKE2B 8ce97e6ae81b729fe2ea2bdaa8d90620f1279004f0b73cf7b546ae7f9427dc06f4f11afd251dd669ca044db5a7eca2602c2652fd4c85b759ca7db3e15daed53e SHA512 82902d1a18ce9e9b3088bfb61fe10366eadc2cc48869d995e3126c14e1abf42112e1b28739a782aa78301571291b044a6923e2ea125feee6b85b38e2d73f53a2
+DIST scikit_build_core-0.7.0.tar.gz 197884 BLAKE2B f632cc131af9db03db2c84b32e451c6369273f9d5db0bca2991cface419c5f9faa5d98239a8a5edd8a36749bc368c0f3c25b3813f33ed63f125731ba4e3d11ae SHA512 ee50070156030fe6c8e07db428902bec67e2267bf36338e62bd936e63f402da869fc4c629c0bc274ab6f798642d163906cc8d6695a62228580ba979878e5d6f8
diff --git a/dev-python/scikit-build-core/scikit-build-core-0.7.0.ebuild b/dev-python/scikit-build-core/scikit-build-core-0.7.0.ebuild
new file mode 100644
index 000000000000..f798d2c34185
--- /dev/null
+++ b/dev-python/scikit-build-core/scikit-build-core-0.7.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Build backend for CMake based projects"
+HOMEPAGE="
+ https://github.com/scikit-build/scikit-build-core/
+ https://pypi.org/project/scikit-build-core/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# we always want [pyproject] extra
+RDEPEND="
+ >=dev-python/packaging-20.9[${PYTHON_USEDEP}]
+ >=dev-python/pathspec-0.10.1[${PYTHON_USEDEP}]
+ >=dev-python/pyproject-metadata-0.5[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/exceptiongroup[${PYTHON_USEDEP}]
+ >=dev-python/tomli-1.1[${PYTHON_USEDEP}]
+ ' 3.9 3.10)
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/build[${PYTHON_USEDEP}]
+ >=dev-python/cattrs-22.2.0[${PYTHON_USEDEP}]
+ dev-python/pybind11[${PYTHON_USEDEP}]
+ >=dev-python/pytest-subprocess-1.5[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO / we don't package validate_pyproject anyway
+ tests/test_schema.py::test_compare_schemas
+ )
+
+ epytest -m "not isolated and not network"
+}