summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-17 09:15:24 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-17 09:36:52 +0200
commitdc1d48e7c31ff369246c5743531ca2c6d8e4f702 (patch)
tree5f9f3fee8836303e63d2cefbd048508c020a2fdb /dev-python/rq
parentdev-python/sphinxcontrib-bibtex: Bump to 2.2.1 (diff)
downloadgentoo-dc1d48e7c31ff369246c5743531ca2c6d8e4f702.tar.gz
gentoo-dc1d48e7c31ff369246c5743531ca2c6d8e4f702.tar.bz2
gentoo-dc1d48e7c31ff369246c5743531ca2c6d8e4f702.zip
dev-python/rq: Bump to 1.8.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/rq')
-rw-r--r--dev-python/rq/Manifest1
-rw-r--r--dev-python/rq/rq-1.8.1.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/rq/Manifest b/dev-python/rq/Manifest
index 48accd1f2a56..47452569ff29 100644
--- a/dev-python/rq/Manifest
+++ b/dev-python/rq/Manifest
@@ -1 +1,2 @@
DIST rq-1.8.0.tar.gz 584251 BLAKE2B 3da1d4f1604a57e16e26c39643337fb8ab804089f783d6a7c44500f577a326cf4883835c996427e819896faad512b9a380ebfdcf67e865eec475d39321ecd2f5 SHA512 e8946b4454e67bc9ce0c69c302ba3bb6403654cce384904d64996766227ba8fdcbff834a8901a8fa09dcccebe8aba769d38daf228283f4142166fa5ea0f9a107
+DIST rq-1.8.1.tar.gz 585211 BLAKE2B 17feb07cb376c5aef88a7aab6d716f58a19f62f19db6c6b0490b4f666981e40304c6a23c88669a0aef9b75a39ce8cb85a9b10a2d42e83e646cdcb6282167d8f9 SHA512 b9df7b4e894a5da693827ff720be3068336d82d2f17928faf5ae6133b042ac2f98a3d673bb2ed86c9351479669e9ef0e4fffcb1dba9b8853f6f793db4a4678f8
diff --git a/dev-python/rq/rq-1.8.1.ebuild b/dev-python/rq/rq-1.8.1.ebuild
new file mode 100644
index 000000000000..61e8398709eb
--- /dev/null
+++ b/dev-python/rq/rq-1.8.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="simple, lightweight library for creating and processing background jobs"
+HOMEPAGE="https://python-rq.org https://github.com/rq/rq"
+SRC_URI="https://github.com/rq/rq/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/click-5.0[${PYTHON_USEDEP}]
+ >=dev-python/redis-py-3.5.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-db/redis
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/sentry-sdk[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests --install pytest
+
+src_test() {
+ local redis_pid="${T}"/redis.pid
+ local redis_port=6379
+ local redis_test_config="daemonize yes
+ pidfile ${redis_pid}
+ port ${redis_port}
+ bind 127.0.0.1
+ "
+
+ # Spawn Redis itself for testing purposes
+ # NOTE: On sam@'s machine, spawning Redis can hang in the sandbox.
+ # I'm not restricting tests yet because this doesn't happen for anyone else AFAICT.
+ elog "Spawning Redis"
+ elog "NOTE: Port ${redis_port} must be free"
+ /usr/sbin/redis-server - <<< "${redis_test_config}" || die
+
+ # Run the actual tests
+ distutils-r1_src_test
+
+ # Clean up afterwards
+ kill "$(<"${redis_pid}")" || die
+}