summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Wingate <parona@protonmail.com>2023-11-13 14:56:36 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-11-13 14:53:23 +0100
commit55f6dbf059964ed4cc3c2c297a7955652916d193 (patch)
tree28f9869f500060ca688497490742f1d1f3a58cbb /dev-python/rpy
parentdev-python/argcomplete: Bump to 3.1.6 (diff)
downloadgentoo-55f6dbf059964ed4cc3c2c297a7955652916d193.tar.gz
gentoo-55f6dbf059964ed4cc3c2c297a7955652916d193.tar.bz2
gentoo-55f6dbf059964ed4cc3c2c297a7955652916d193.zip
dev-python/rpy: add 3.5.14
Closes: https://bugs.gentoo.org/906816 Signed-off-by: Alfred Wingate <parona@protonmail.com> Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/rpy')
-rw-r--r--dev-python/rpy/Manifest1
-rw-r--r--dev-python/rpy/rpy-3.5.14.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/rpy/Manifest b/dev-python/rpy/Manifest
index 58908c40214a..9b5346f571ec 100644
--- a/dev-python/rpy/Manifest
+++ b/dev-python/rpy/Manifest
@@ -1 +1,2 @@
+DIST rpy2-3.5.14.tar.gz 219268 BLAKE2B 167284d4974710121475d83aada49e128566f075276f5f641096f6ce94c236c315617df2847504e0e3ca804090e1f422fa1b53a4a37b60f1c5bcdba8c0b059ff SHA512 d02454fb41c946a0a92547f8a5dba3c614741bec8e293984116b34dfbe97574a655b7066fd75d34fee4c0f604c41c8b672d6a2c3b4194cba30a37c95da6578dd
DIST rpy2-3.5.8.tar.gz 214245 BLAKE2B 70d6b1e07df3fb6936898ab1353f134a4184ce611486c3da875ca7b562ec9a60bde9657869807aab969ccf515a32cf2a3767704e8ed8ab8b8977b9ac15745033 SHA512 e0781aeea4e483e60c2e54322bc577e5314627c6ef881387af6011e5ef3c08b4ee1be16bcbeba9083dcd0758655fc83a1ff474a3e05291745f85d94a70437521
diff --git a/dev-python/rpy/rpy-3.5.14.ebuild b/dev-python/rpy/rpy-3.5.14.ebuild
new file mode 100644
index 000000000000..dfffe5235fa0
--- /dev/null
+++ b/dev-python/rpy/rpy-3.5.14.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi optfeature
+
+DESCRIPTION="Python interface to the R language"
+HOMEPAGE="
+ https://rpy2.github.io/
+ https://github.com/rpy2/rpy2
+ https://pypi.org/project/rpy/
+"
+SRC_URI="$(pypi_sdist_url rpy2)"
+S="${WORKDIR}/rpy2-${PV}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-lang/R-4.0
+ dev-python/cffi[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/tzlocal[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "ipython integration" dev-python/ipython
+ optfeature "numpy integration" dev-python/numpy
+ optfeature "pandas integration" dev-python/pandas
+}