summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-19 09:34:37 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-19 09:43:23 +0200
commitf26b054af688f1b482ca210ec081c0be9460078e (patch)
tree131e690659290434d3bb5dc6a5e7e42279f6b6ca /dev-python/ropemode
parentdev-libs/libgit2-glib: Bump to 1.1.0 (diff)
downloadgentoo-f26b054af688f1b482ca210ec081c0be9460078e.tar.gz
gentoo-f26b054af688f1b482ca210ec081c0be9460078e.tar.bz2
gentoo-f26b054af688f1b482ca210ec081c0be9460078e.zip
dev-python/ropemode: Bump to 0.6.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ropemode')
-rw-r--r--dev-python/ropemode/Manifest1
-rw-r--r--dev-python/ropemode/ropemode-0.6.1.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/ropemode/Manifest b/dev-python/ropemode/Manifest
index 31b0ea40d2d8..0544969573b9 100644
--- a/dev-python/ropemode/Manifest
+++ b/dev-python/ropemode/Manifest
@@ -1 +1,2 @@
DIST ropemode-0.5.tar.gz 15328 BLAKE2B 051c92a6105c0226c2a2daafbb55485327fcb8777467fc4ff86e1491f9fbbe39cec90100c212ebc64d08d6b1803638597eea0852222f29187b6fe92542a80b3c SHA512 50740982a731045734150171e0c3ae26ccf64bef4699fc7062204c68750b760a373d5b2b0e00b8ba8057d3955059ca1dce2a41cc1878775698184d78f921b76c
+DIST ropemode-0.6.1.gh.tar.gz 17062 BLAKE2B fb7dd0d4b4874bcf8ccad5b9b759a46b17cb8a0c6e473b4402db3df0ad8e1cd0f1d42b07822d0bcd4113e8590bb49a7acc735d1bb923b1525e4aa8864a18e10f SHA512 c56a9306ab60a16a18186c28221d297ca1bb350ad64dc02d679e61f575fb88835c091a9fb02754f54cc7af8d0f311313a3435dd7018c912f43417fdfd78035f9
diff --git a/dev-python/ropemode/ropemode-0.6.1.ebuild b/dev-python/ropemode/ropemode-0.6.1.ebuild
new file mode 100644
index 000000000000..e43b13d2d502
--- /dev/null
+++ b/dev-python/ropemode/ropemode-0.6.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A helper for using rope refactoring library in IDEs"
+HOMEPAGE="
+ https://github.com/python-rope/ropemode/
+ https://pypi.org/project/ropemode/
+"
+SRC_URI="
+ https://github.com/python-rope/ropemode/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/rope[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest