summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-02-25 18:57:09 +0100
committerSam James <sam@gentoo.org>2021-02-26 14:25:49 +0000
commit562a6a9a798cecc56826d40f2c897114ae976344 (patch)
tree99328a4fd53ab146aa795b68dcb8abb359aaa3a2 /dev-python/rich
parentdev-python/nbval: Mark ALLARCHES (diff)
downloadgentoo-562a6a9a798cecc56826d40f2c897114ae976344.tar.gz
gentoo-562a6a9a798cecc56826d40f2c897114ae976344.tar.bz2
gentoo-562a6a9a798cecc56826d40f2c897114ae976344.zip
dev-python/rich: Library for rich text formatting in the terminal
Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/rich')
-rw-r--r--dev-python/rich/Manifest1
-rw-r--r--dev-python/rich/metadata.xml13
-rw-r--r--dev-python/rich/rich-9.11.1.ebuild28
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/rich/Manifest b/dev-python/rich/Manifest
new file mode 100644
index 000000000000..22831fe8e7bb
--- /dev/null
+++ b/dev-python/rich/Manifest
@@ -0,0 +1 @@
+DIST rich-9.11.1.tar.gz 14050070 BLAKE2B 7dcae32743bfcbbab0af6896f72e865d2a72ab66545168544d065145cf10a2aab4785454e547f011219a85a8aa762f1ed5ebef2b9fb7f44225a2f776835b643d SHA512 2139cb6602d930e9bf1479456a8e6cee812237fb64073db3f23fd8eab64c1c2b3a83c6292f1f90652791100a93961d8ec8036e5d819f1e23159b6b9a75cd1f6c
diff --git a/dev-python/rich/metadata.xml b/dev-python/rich/metadata.xml
new file mode 100644
index 000000000000..ee58016921d5
--- /dev/null
+++ b/dev-python/rich/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chainsaw@gentoo.org</email>
+ <name>Tony Vroon</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">rich</remote-id>
+ <remote-id type="github">willmcgugan/rich</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/rich/rich-9.11.1.ebuild b/dev-python/rich/rich-9.11.1.ebuild
new file mode 100644
index 000000000000..e0b55024c35e
--- /dev/null
+++ b/dev-python/rich/rich-9.11.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Validate configuration and produce human readable error messages"
+HOMEPAGE="https://github.com/willmcgugan/rich"
+SRC_URI="https://github.com/willmcgugan/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/commonmark[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "integration with HTML widgets for Jupyter" dev-python/ipywidgets
+}